Problem With CUDA GPU Compute

Hi all,
I have alittle problem with GPU compute and Cycles.
Blender 2.62 + GeForce GTS240 - driver version 296.10.

When I start rendering in the 3D view I’ve got this message
“CUDA device supported only compute capability 1.3 or up, found 1.1”

Is the GeForce too old or I have to update some drivers?

You need more recent hardware, IIRC 560 or better. There are some hackish builds (and patches) that allow compute on that old 1.1 compute capability, but do not expect too much speedup for that, maybe CPU will be even faster on some configurations.

Simply see if you have Feature Set to Experimental. I’m too on that “older” - 9800 type, still, it renders miles ahead of cpu. Provided, that you have set cuda in user preferences tab.

Wow, no… GTX 260 and up use ‘compute version’ 1.3 - which works, though not will AO… GTX460 and up use 2.0…

Wow, am i only one lucky here?

I get AO on CPU, that was pretty obvious just testing it, hehe… ;D

But there might be something else at play… What OS are you on? And what build? I see you put it on GPU in the settings, but a 9800GT shouldn’t work with Cycles at all so you use some homecooked build or what?

@Farmfield, I got ao with a GTX 260 if I set “Feature Set” to “Experimental”.

Cheers, mib.

Yeah, and I bet Eppo is on GNU/Linux too then, CUDA compilation issue on Windows perhaps? Gnnn, it just doesn’t work other than w/ CPU…

(I could check it in Linux on this box but I don’t wanna run Blender in GNU/Linux as I want to use the Maya shortcuts, and that doesn’t work in Gnome… :P)

@ Farmfield: You won that… Fedora, homebrew svn. I was affraid after all that ‘non supported’ buzz that i’ll have to go shopping for a new gpu, then gave a try… It would just work.

Then it’s not the ‘compute version’ if 1.3 works in GNU/Linux and not in Windows… Very weird indeed. So, in all likelyhood, it’s the Windows driver. Sounds improbable, but what else could it be? :stuck_out_tongue:

Thanks guys, problem is still here, I will go on with cpu for now