Problem with "double sided" faces

Hi. I’m making tree for game and I had made few tress and they were fine but now I’ve wierd problem. In game engine faces looked like UVs were wrong; I thought that’s problem with double sided faces so I jumped to blender and I wanted to uncheck this option but faces are sill heading in both sides, normals are set ONLY in one side, I have two UVs and materials: one for main trunk and second for branches.
Even if I selected option “backface culling” I can see both sides of leaves, but when I’m “inside of trunk”
this option works (but only for trunk) - I think you know what I mean :wink:

Thanks for help,

it depends on the game engine, each one has a different method of dealing with backfaces. the most robust solution is to simply copy the face, then flip the normal. this is similar to what disabling backface culling does anyway.