Problem with dupli groups usage: all instances acting like one (blends incl.)

Hi! After some trials, here I am to post this problem.

I’ve created a library of doors ready to use in a game, made all the logic through Python and all, and grouped all the related objects of this door into one group. In another project, I LINKED the group and instanced two of these doors. However, when I open one door, the other does the same thing. I thought that it was some mistake of mine, so I refactored the logic some times, tried to access the objects of the actual door through own.parent.children, then own.groupObject.groupMembers, and it stands as it is, acting like just one object, both doors opening at the same time. Then, I tried to APPEND the group and it worked as individual doors, just like it is meant to be.

Actually, appending the group is ok, but the link is better because it updates the group if I make changes in the source, what is better if lots of the same resource are in different scenes (the case of complex games), but I thought that the objects were make local at runtime or such when linked.
Is there another way through this, I’m wrong at some point of my logic or the instances really have this limitation of being the same object?

The projects are included in the zip, with a script .py, two .wav sfx, two .png textures and three .blend of the door library and demos for both link and append.

Door (Link and Append Differences).zip (430 KB)

you can’t use a message sensor / messages for this,
(all instances of the door receive the messages)

just have the objects connected across using logic even if the actuator does not do anything, it gives the controller a direct link to a object using a locked reference.


cont.actuators.unusedMovementSensor.owner[‘Property’] = True


Thanks, BluePrintRandom, it solved my problem, now it worked using the connected sensors instead of messages through the objects.

Result is below.
Door (Linked Library Fixed).zip (297 KB)