Problem with fluid simulations -it's not supposed to do that!

I have modeled a basic vase and i’m trying to make some fluid splash out of that, but i have faced some problems

1.Nothing is happening,nothging
2.I noticed that the domain object has turned into a small spherical object that seems to be the fluid simulation (it is moving like that)
3.I re modeled the vase and did everything again and domain worked fine, but fluid was not interracting with obstacles ( i have set them as obstacles for fluid sim)

This is just horrible, cause fluid sim has somehow always worked for me, until now

Some help please!

And once again sorry if there is some bad english;)

It might be helpful if you post the .blend-file.


You need to change some settings. The cup should have volume initialization set to Shell; the cube should be Type Fluid. You might also want to try a more recent build of Blender, I could not get fluid to work on build 36431 but it is working on build 36509.

I forgot to add that I scaled down your objects and removed the subsurf modifier from the cup. It appears that it is this subsurf modifier that stops the fluid sim.

But that thing in the cup is supposed to be the fluid :smiley: and also AlanK, do you mean that i should change the falling cube or domain cube into fluid? Thanks for reply!

I was not sure from your blend file what was supposed to cause the splash. I have modified the mesh for your fluid and cup, and animated the cube obstacle falling into the fluid. If you want subsurf on the cup and fluid you should add it after you have baked the fluid sim.
Splash!1.blend (412 KB)

But the fluid still goes through the cup :frowning: even it is obsitcle !
And why is the domain turning into fluid? This isn’t as easy as i thought :smiley: