Problem with importing a mixamo character into blender

Hi all, I have created a character in mixamo, used their auto-rigger tool and tried to export it to blender following the instructions from that link:

In blender, when I switch to texture view, my character is completely black. Anyone could help me fix this?
I attached a photo of the character.

(there also seem to be some issue with the auto-rigger as you can see on the picture…)

Attachments


Moved from “General Forums > Blender and CG Discussions” to “Support > Materials and Textures” (though if it’s a problem with the importer, it may be better suited for the Technical Support forum.

The figure was black because of bad lighting…
Now only the question about bad rigging remains

I know this is an old post, but it is still happening, and I found the solution-a solution that those new to Blender can use. I haven’t found it solved anywhere, so I’m posting the answer to all places I find the question. Most replies said: prolly the UV, add a light. Not helpful. Note: I am not a developer, I’m a teacher trying to help my kids get going in 3d…I’m not well versed with lingo and protocols. I offer my solution in laymen’s terms. Please, experts, feel free to expand or explain or correct me on why this works.

Problem: for some reason the fbx Mixamo models are imported with 100% opaque faces (except the body in my case…it was just the facial animation map pieces). No amount of “lighting” or “UV” helps if they’re not using the alpha supplied in the png!

Solution:

  1. In the 3D view, in Object Mode, in Orthographic (idk if this matters), open the armature layers panel and the properties panel (if it doesn’t auto-show below layers)
  2. expand armature layers (click white arrow for dropdown), and expand all the orange triangle layers (underneath the bones layers). Keep expanding orange triangle layers until you see the red sphere icon in each.
  3. Click/select/highlight the first red sphere icon for a body part that shows as black in your view
  4. Now underneath, (default Properties of that layer) click the red sphere section second to bottom and scroll down past Preview, Surface, & Volume to SETTINGS. (click to expand settings)
  5. Note Blend Mode & Shadow Mode are set to Opaque. This means the png’s transparent background isn’t showing, just the black (as if it had been saved as jpg).
  6. Change Blend Mode to Alpha Clip or Alpha Hashed. Voila!
  7. Repeat for all pieces that are showing as black

I am not an expert so idk which is better-hashed or clip- they both seem to do the same thing. I had some issues later when I chose “Alpha Blend” and I have no clue why, so I stuck with clip and all seemed to do what I wanted :smile: And FYI I didn’t see a difference when I changed “shadow mode” to alpha, but seems like should probably match whatever you pick for Blend Mode?

I apologize if this is not a “developer level” answer, and that’s expected here, I just wanted to help the noobs and kids without making them go take a 6 week course on “So you want to learn animation”. They’re 12. Give em a break :wink: