Problem with insert function

Hi all! I am new to blender and was modelling a house by seeing a tutorial… And when I started off for designing the windows this happened.
Now everything is fine except for the Insert function… (or whatever function starts with the ‘i’ key). Whenever I use that function… Assuming I use it on a square so I should get a square in between with the walls coming equally on all sides right?? I mean that is what happens in the tutorial… I’m using blender v2.74 and the tutorial is for v2.68 but everything else goes fine except for that function, tried playing with the settings but nothing helped :no:… Posting a pic

Link of tutorial -


Most likely a non-uniform object scale. Object scale is visible in object mode, 3d view properties (hotkey N) -> transform. It should be 1,1,1 which it probably isn’t, so ctrl+A -> scale to apply object scale to the mesh and reset the scale.

You also have double geometry. After applying object scale, edit mode, select all, W -> remove doubles.

Whenever you link to a video, try linking with a timestamp that jumps to the relevant parts. No one is going to watch a 17min video just to give you an answer unless they’ve already seen it.

Sorry about the timestamp friend I was in a bit of hurry… Now pressing Ctrl + A doesn’t opens any menu or something and W -> Remove doubles also doesn’t helps… :frowning:
EDIT: Did the same in object mode and worked like a charm… Thanks a lot!