problem with mist on a "only shadow plane"

I´ve done a picture in terragen, which i used as background in my blender scene. I wanted to insert an ufo on my plane, so i worked with ter2blend and got my terrain in blender as a only shadow material. That worked so far, but in in my terragen scenery i have some mist, so i wanted to have some mist on my blender object… but when i switch on the mist botten my object becomes transparent??

Any suggestion what it could be - or how to solve the problem?


Mist can be tricky. Set the mist button on in the camera buttons so that you can see the range of its effect as you change values.

sta: the distance from the camera to where the mist starts
di: the distance from the mist start to where the mist engulfs everything
misi: set to zero to start and increase gradually to increase the mist effect (I seldom use more than 0.4).

I tried with a shadow only material and it worked here.


Thanx, but i think this is not my problem, i did the settings and the mist is in place (camera settings). But i dontt see mist, its that the objecs getting transparent! (it`s like i would the decrease the alpha value…?!)
So i got only 1 object in the scene (the UFO) and a picture for the background in the world buttons (the terragen pic) and the plane with only shadow (the imported terrain).

Just to clarify, i want the mist only on my object and not on the only shadow plane…


I think I understand now. Mist, I gather, works by taking the world color or image and letting pat of it show through. This with a picture in the backbuf makes the objects look partially transparent. Put your image on a plane (parented to the camera) in the background rather than using the back buffer and set the world colour to your mist colour. If you don’t want the mist to effect your background plane use the no-mist option.


Thanx a lot - good idea!!
I didn`t know that mist works that way!
I will try that, but it sounds to be the right way!


Nearly, but now i got the whole plane in my mist color… of course! The plane is a only shadow plane :frowning:
Any ideas how to deal with that problem?

If you`re interested in some pictures…: