Problem with motion blur on deformed mesh

Hi guys !

I did an animation on Maya and baked it to import it in Blender for rendering.
When I click on the “motion blur” button it dosen’t work at all. It seems like motion blur works only on non deformed object.
Is there another way to render motion blur ?

I also tried with the vetor blur node…doesn’t work either :confused:

Blend file ?

Problem solved :slight_smile:
I had to disable the “auto smooth” in the object data. But the sampled motion blur was too slow to render… So I used the vector blur node in the compositor which was way faster !

If you guys know another solution to render motion blur without disabling the “auto smooth” button I’ll be very happy to know !