Problem with mp4, and transparency

Hi everyone, i want to play a mp4 of a flame and have the background transparent, My best guess was this, in cycles.

i would be grateful for all help



It looks set up right. But maybe your video doesn’t have transparency. Not all containers (mp4, avi etc) support transparency. Quick googling says, no, mp4 doesn’t support alpha.

Here, though, it really doesn’t matter, because you could run it into emission and add shader with transparency. Black emission isn’t anything, so black + transparent = transparent:

Note also that a material preview uses Eevee rendering, which has additional material needs for setting up transparency. Just saying this because your screenshot is awfully clean for a Cycles rendered preview. If you want to see what it will look like in Cycles, use a rendered preview instead of a material preview.

1 Like

You video has not alpha channel. You can only use with “Color Mix > Multiply”.

1 Like

Thank you for your reply, I did lots of different things to make it work, exported it as an image sequence in premiere , exported it as a QT, i still couldn’t shake the grey frame, the last thing i tried was to use the color from the image texture instead of the alpha and that worked, iam loosing some of the complexity of the video, but i guess thats fine.

take care

its now a QT with alpha,

I tested your way and its much better, keeps more color! thank you