Problem with normals, but worse than that :(

Crazy normals or something, need help making the foot not look like its been in a “blender” haha but seriously…

So I’m studying at the University of Utah and I’m making my own human body in 3D. In the class our instructor didn’t have time to show us how to do the foot so he told us to use his. I imported the OBJ he gave me into blender and everything was fine. It looks good in the view port, even in textured view it looks OK. But when rendered, it looks crazy and awful and “triangle-y” and crazy. I’ve tried looking at the normals and they are all facing outwards and I’ve tried making normals consistent but that didn’t help. This sometimes happens when there is a duplicate of a mesh on top of itself, but I made sure there wasn’t any extra vertices[AT

TACH]204724[/ATTACH]. Anybody have any idea what could be the problem? The foot was made in Maya then exported as OBJ in case that matters…
I attached a pic of the problem and the blend file with the foot


problematic_foot.blend (648 KB)

I don’t see any specific problem , it’s very odd.

But probably linked to that problem, if i click on that foot, then go to edit mode, it will crash Blender 2.65 RC1 instantly.
While Blender 2.64a has no problem with it.

I would report this new bug as it’s still time before the official 2.65 release, but that’s not my blend.
So can you report this on the bug tracker, or would you allow me to do it with your blend ?

It looks like there’s indeed lots of faces doubled and so overlapping (delete a face in edit mode and notice how there’s another one under it, but very strange is that W->Remove double is unable to fix that problem.

See the faces that are in a different shade of orange, it’s where the faces are all doubled.
And it correspond exactly to the area you observe the rendering problem.

But what is really strange is that the vertices are not doubled , it’s only the faces that are (and probably why W->Remove Double is unable to fix that), very likely a bug that need reporting.

Haha this is so weird. Yes you have permission to report the bug, I fixed the problem by going in and deleting a few faces at a time. It just destroys the top layer and leaves the other faces behind. I can only do a little at a time though, if i did all the bottom and selected faces then delete, it just deletes the foot. Thank you so much for your help!

Try selecting anything that’s non-manifold and deleting those. Or you could increase the search distance for the remove doubles tool, just make sure not to make it high enough to wreck the geometry in the toes.

Just downloaded the foot… non-manifolds don’t work. Hmm… interesting.

It seems that somehow there are faces that aren’t made of any verts. Never seen this problem in 7 years of working with Blender haha.

OH, importing .OBJ files. So many things that can go wrong, and so little time to fix them. What everyone said is good advice, but it basically comes down to a lot of work on your part. I’d suggest first deleting duplicates. Then zooming in on each vertice in the problem areas, and merging. There are probably some areas with multiple overlapping vertices, while other areas will only have the necessary one vertice.

Then there will still be problems, so you have to delete each problem face, by itself, and make new faces to replace them. This might have to be done two or three times on the same face, if the adjacent faces also have problems and after the adjacent faces are repaired, you find some you worked on previously need to be replaced again. I don’t know why this is, but it happens. Sometimes deleting the faces isn’t enough, if you have a problem face that just won’t work, delete edges. In some areas you will probably find multiple overlapping edges, some completely unattached to a face.

THEN check normals, and you will probably need to re-orient some, or all. Maybe even delete and make a few faces again.

THEN check for duplicates and orphaned vertices and edges. There always seem to be a few around. I select the ‘finished’ mesh, move it out of the way just a bit, and almost always left behind are a handful of vertices and edges. At some point you will be done and will have clean mesh. Of course you will loose your texture, but this is the only way (I know of) to clean the mesh.

And your teacher should be ashamed to be providing you with such an inefficient model. He should have converted this before he made it available. Unless, his plan all along was to teach you the work involved in importing .OBJ files.

I reported the crash + doubled faces with no vertices on the bug tracker here :

Hopefully the devs will see what’s going on

i troed to check for any double verts by removing some fo the verts
and cannot reproduce the problem for doulbe verts!

but your right trying t render this becomes a nightmare!

try to add a edge split then a subsurf and you can see very strange hex faces on foot then render it!

very strange indeed!


I just exported it out of blender as a new .obj export and then imported the same model back in and it fixed the double faces problem the linked .obj had. Hope this helps.

did another test and very bad !

i save as legacy imported in 2.49 and there was still no faces !
then back in 2.5 and added a few faces it is working like that
but need to do the faces manually!

this could be an import problem making a bad mesh in 2.6!


I’ve had this type of thing happen while modeling in 2.63.

think iv found a fix, certainly an interesting problem, i just removed the double faced faces by selecting the darker shaded faces only and pressing p to separate them to a new object then in edit mode deleted it afterwards

Hi. i was looking into this report but I can’t find the original OBJ (which I need to investigate the bug).

I tried to contrive an example OBJ with duplicate faces but this imports fine without duplicates (notice last 3 faces are doubles)

v -1.000000 -1.000000 1.000000
v -1.000000 -1.000000 -1.000000
v 1.000000 -1.000000 -1.000000
v 1.000000 -1.000000 1.000000
v -1.000000 1.000000 1.000000
v -1.000000 1.000000 -1.000000
v 1.000000 1.000000 -1.000000
v 1.000000 1.000000 1.000000
f 2 1 5 6
f 6 7 3 2
f 7 8 4 3
f 1 4 8 5
f 1 2 3 4
f 8 7 6 5
f 8 7 6 5
f 8 7 6 5
f 7 6 5 8

I sent a PM to the author of the thread in the hope he will be able to provide the OBJ.

is it not the problem having multiple faces at same location?

and why is remove double not working in this case !
this removes only verts but not the double faces !
do we need a new tool to remove double faces or edges now!


@RickyBlender, double edges and faces can exist in our data-structures but they should not be possible to create.

so the bug is — how did you manage to get blender to make this?

  • this is whats missing from the report :S

up to now never seen a model like that!
as long as we don’t see this again it’s nice

but like you said how it was created in blender is the question!

i also PM author hope he an upload the obj file soon


Edit mode:
select all, extrude invidual faces (no move), select all, remove doubles