Problem with particle/mesh rotation and touch ground (Blender 2.8)

Hi All :slight_smile:

I searched a lot here on the forum, but I didn’t find anything useful. I have two problems with a PS

  1. The mesh instance that I set in the particle system, in some places does not touch the ground. I tried everything but nothing. In the example, the particle is set to emit from “face”. Tips? Solutions?

  1. I can’t set/randomize the rotation of the particles/mesh on the Z axis. How to do?
    This serves me to rotate the grass group to make the total appearance unequal.

Thanks for any help!! :slight_smile:

Hi, try this and a few posts below: Modular Tree
Or in less code speak: How to make objects Emit Perpendicular to Surface?

Edit: While the above would snap the particles onto the faces you probably don’t want to rotate them according to these face normals as flora mostly grows against gravity.

It would be easier if each particle wasn’t so wide at the base as this results in the floating you’ve pictured. I’d try different particles that are pointed / narrow at the base or at least make it only one bush / root per particle.

1 Like

Thanks a lot @LoboTommy !! I read with pleasure the two links you posted to me :slight_smile:

1 Like

No probs. The first link lost the old thread I pointed to. Found the second one while looking for it by title. If the above fixes your problem could you mark the thread as solved? Happy blends.

Of course! Tomorrow I try the solutions as they are now on a different PC and I can’t try :slight_smile:

@omgold solution is the partial goal:

“You have to do for the particle system: Enable Rotation, Set Iintial Orientation to ‘Normal’
and Check ‘Rotation’ in the Render tab”

Ok, the threads were really useful to me but I’ve made some changes for my scene.

In primis, I adjusted the rotation of the grass object since the Z axis (in edit mode) did not correspond with the global axes in Blender and then I fixed the pivot obj.

Done all this, and used the advice of omgold, I can now use a random rotation with “phase” and “randomize phase” in “Rotation” tab.

Now everything appears to be working (for now :smiley: )

Thanks @LoboTommy for help and suggestion :slight_smile:

1 Like