Problem with saving high-resolution render-image


I have trouble saving a highres-image for print.

Blender will render as normal, but when finished there seems to be no way to save the image. If I press F3 (or do “file/save rendered image”) blender responds with “error: No image rendered”. The rendered picture also turns grey once it’s finished rendering. During rendering I can however see the sections of the picture being rendered just as usual. I have tried to work around the problem by rendering the image as sequence, letting blender do the saving of the rendered frames automaticly, but the rendering stops after the first frame (i tried to set it to a duration of 3 frames, just in case) and still nothing is saved.

Probably this is connected to the resolution I tried to use: it’s for printing as I said, so the resolution is 9933 x 7016 (i.e. A1 at 300 dpi). If I set the rendering-size to 75% everything works fine. Turning off OSA won’t help. I attached a demofile to illustrate the problem.


Testszene_bigframes.blend (173 KB)

Your testfile renders for me fine.
And I was able to save the file to disk.

But there is a script available, which might be worth trying.


Interesting. That leaves only a few alternatives. Either my ram’s too small or my blender-version is buggy. I have however tried to render it on another machine, with similar hardware-specs and came up with the same problem, though. I also tried rendering with version 248a as well as 249.2.
May I ask what blender-version you have, and what Processor/RAM/OS you used?

Thanx a lot for the link you gave me! I found a lot of useful scripts on the page linked from there! ( )

I’m using version 2.49a on OSX-intel 10.4.11 Tiger with 3GB RAM.

I’ve had NotEnoughRAM issues before as well, but allways when running out of RAM during render, Blender simply crashed.

I don’t know how blender handles the rendered imagebuffer, but did you check writing/reading permissions in your tmp folder(though this problem would not happen on two systems).


If blender had no write-permission wouldn’t that mean that rendering is not possible at all? Anyway, the permissions look fine, I checked. My guess is that 2 gig of ram are simply too small. Blender didn’t crash, though which is a mystery to me as well if that’s the case. As you’re using a mac it might be some windows-issue as well, which wouldn’t be a total surprise to us would it?:rolleyes:

Thanks for the help anyway!

"blender responds with “error: No image rendered”

That is a sign of insufficient RAM, definitely try the ReallyBigRender script.

Well then at least I know what the problem was.
I used the ReallyBigRenderscript already to solve the problem. It’s perfect for the purpose, as DIN-Formats double in size with each decrement, i.e. to get a full A1 picture I only have to use A3 resolution and make the script double it, hence doubling it horizontally and vertically to get four times the size. Worked like a dream.

I’ll still buy some more RAM soon, but this script is excellent for producing massively oversized renderings for posters and such.

I used the script recently,and found some weird bugs :

The script works fine from short focal lengths, up to 60 mm lens. After, only the 2x2 parts render gives a correct result. with focal leghts longer that 60mm, and 3x3, 4x4 or 5x5 parts, the scale is not good and the rendered field is much larger that the frame seen in the camera view !

I needed a 90mm focal length and 4x4 parts, and I have not been able to render correctly : the useful image is small in the center of a wide frame !