Problem with Texture Paint mode

I’m not sure where else to post this, so if someone knows where this should go let me know and I’ll post it there.

I’ve been having a problem with Blender in the texture paint mode, basically the model I’ve been working appears to really mess up in one specific area in both the texture paint mode and object mode, but in other modes like sculpt, or edit mode it’s perfectly fine.

Why are there some edges missing on the tip? it looks like that might be where the problem lies.

Oh, I was deleting some of the vertices a bit earlier on because I was getting another issue along the way, and at the time deleting certain vertices seemed to fix the issue. But I’m guessing the reality of it is that it didn’t, and it only made things worse.

Check your Modifier stack and you’ll likely see that your Subsurf and/or Multirez modifiers are NOT enabled for viewing in Edit mode. The Multirez is not viewable in Texture Paint (I think), and it is masking some topology problems that Subsurf, which can be seen in Texture Paint, tends to exaggerate. The missing edges in the Edit Mode pic may be part of the problem, but that could also possibly be fixed by enabling Show All Edges in the Object options. In Object mode both Subsurf and the Multirez can be seen, so again the problem is masked.

All speculation without looking at the .blend, but it’s a place to start looking. I often forget to enable viewing Modifiers in Edit mode because it’s not default, so it’s not like you’ve missed a beat.

Ahhhh, maybe that’s the problem then. I don’t have a subsurf modifier on right now, but I do have a multirez modifier on.

Changing topology like that with Multirez in place can mess things up because the sculpting process is dependent on the base mesh structure. Sculpting done with Multirez can get very goofed up. It also is designed to work with proper quad topology, so if you created n-gons by dissolving vertices, it’s not ideal.