Problem with using Subsurface Scattering with Emission Shader

Hi. I am using Subsurface Scattering and two planes with emission shader to light the model. The problem is, the model doesn’t render correctly. It is just too noisy. I tried to increase the Render Sampleto 300 from 25, but it’s still too much noisy. I even tried to increase the Render Sample to 10000, and it’s still noisy. Take a look to the render screens that I took:

Render Sample: 300

Render Sample: 10000

What’s wrong? I think setting render sample to 10000 is way too much. What do you think? Is it normal? Does Blender has the capability to render SSS with full quality or you should set the render sample to higher values to render SSS correctly?

Share the scene. You’re likely doing something wrong. Looks like your noise is coming from SSS via caustic lighting, which I don’t think a single renderer in existence can do quickly.

0.blend (570 KB)

Here is.

Your glass shader is a mess. Why are you combining Glass, Glossy, and Refraction with arbitrary values? Just use Glass + transparent, and mix with Is Shadow Ray.

Go into Render settings and turn off reflective and refractive caustics or you’ll never get a clear scene. Caustic -> SSS is an almost impossible path for a unidirectional path tracer to solve.

Additionally, any scene with glass is always going to look ugly without something to reflect. Without HDRI or an actual scene to put the object into you’re not going to be able to really work on your materials and lighting.

I’ve deleted the all shaders except Glass shader but it’s still the same. :frowning:

Your glass is huge. While Blender is pretty much size agnostic as far as modeling is concerned, rendering usually works best with objects having real world scale: 1 Blender unit = 1 meter in Cycles. Your glass of milk(?) is roughly 9 meters high and 4 meters across - got milk? :wink:

So, after scaling the glass down to a more fitting size (and adjusting the scale value for the SSS shader) and using all of m9105826’s tips (turn off caustics, refined glass shader, HDRI background) I get this with “just” 1000 samples:

I liked ikarishinj’s render so much that I made the changes recommended by m9105826 and ikarishinj and a few other changes and rendered. It’s got painted green planks. :eyebrowlift2: It starts getting clean around 4000 samples, this is 10,000 with filter glossy at 3.

The milk shader could use some work, I’ve been tweaking here myself, but whole milk should have more of a “buttercream” scattering color, while skim trends closer to blue. The red is a bit strange looking.

Just found this nifty BSDF:

This is where I ended up.


Our milk’s a remarkable stuff
and subsurface can really get tough.
But with pleasure we drank,
put the glass on a plank.
Would’ve preferred a beer sure enough…

Now, seriously (and non poetic): Subsurface scattering has always puzzled me - in any 3D package I was working with. Never got it looking quite right…

IkariShinji, I did it but it’s still the same. I don’t know how to turn caustics off though. Looks like I should take a look to some tutorials before I try to experiment with SSS. Your render looks very good also. Thank you guys for your help. Looks like you guys liked the model, you’re using it for your experimental renders. :smiley: Thank you very much. I can’t solve my problem. :confused:

You turn caustics off in the “Render” tab:

Mine is definitely the worst of the bunch but feel free to look at the settings.

Milk on dropbox

It looks very bad, I’m very embarrassed. :frowning: When I turn off the caustics, milk gets darker. I tried to increase the energy of emission planes but it won’t work.

Did you really follow all the advice given here? Checklist:
a) Caustics off?
b) Glass shader?
c) Scaled mesh down to real world scale? Done Ctrl-A > Scale afterwards?
d) After doing c): Scale in the SSS shader adjusted?

Node setup b) and d):

Much better. Thanks.