Problem with volumetric shadows


I’m working on a project and I need to produce a volumetric shadow for a character that’s bathed in a strong beam of light (image below).

Problem is that I get these ugly artifacts

I set the halo step to 1 and tried to play with every setting in the Shadow and Spot panel (specially Shadow Buffer Size), but nothing works. How can I create perfect shadowing like the images below? Also I need to render the shadow out on a separate pass but I can’t. They seem to be neglected in shadow passes. Does anybody here know a way to produce a volumetric shadow pass?


first off, awesome project. i really like your style. ok, so try bumping ‘Samples’ and ‘Halo step’ to max. in this case thats 12 and 16 or something… and then with your ‘ShadowBufferSize’ test at these values… 512 / 1024 / 2048… hope this helps. all the best

Thanks. I experimented with these settings but I didn’t get any improvements in the result. And by the way, halo step doesn’t work the way you expect. Actually you get the cleanest volumetric shadow if you set halo step to 1. But it seems that the geometry of the object placed in the spot light also has a considerable effect on the quality of the shadow. In my case I guess there just isn’t any combination of settings that would give me the result I want because the geometry/pose of the character is just too complex to produce a clean shadow. I guess I’ll just have to make it in post pro :frowning: