Problems importing materials into Unity

I am having a problem importing Blender (2.76) models into the Unity (5.3.5f1) game engine. The models work but they cannot be textured successfully. I first tried a rather complex model and applied a material w/ texture to it in Unity. It looked as though a few pixels from the texture were spread over the whole model.

I decided to remove all the variables and just export a default cube into Unity. I exported as native Blender, then FBX and then 3ds. I tried adding materials in blender but also applying them directly in Unity. I dragged the material on to the cubes. All I got was a solid color taken from somewhere near the center of the texture. When I created a cube in unity or a plane things work fine. I tried using 1024x1024 maps and a 100x100 map, same problem. I tried adjusting the tileing from .01 to 100 with no help.

To summarize: it appears that a few pixels from the center of the texture are spread over the cube and the outer part of the texture (90%+) is ignored.

The process works fine for native unity objects….

You did UV unwrap the objects in Blender, yes?