Problems with Blender 2.47 on Ubuntu Hardy Heron

Blender itself functions very well in Ubuntu. However strange things happen. Blender is shown full screen. At the same time some arbitrary parts of Ubuntu are also shown locally.
Also I’m not able to switch to a different workspace. I’m stuck with Blender. So no multitasking is possible.

Sounds familiar?


I don’t have those problems but I think it might be caused either by your graphics card drivers or your compiz settings.

Try System>Preferences>Advanced Desktop Effects Settings>Workarounds, and turn off fullscreen legacy support. It sorted out some problems I had.


Can anybody give the Dutch language version of this path:

System>Preferences>Advanced Desktop Effects Settings>Workarounds

I can find systeem>voorkeuren, but then I don’t know about Advanced Desktop Effects Settings.

Hmm, perhaps you don’t have it installed. Go to Applications>Add/Remove…

Search for Advanced Desktop Effects Settings (ccsm) and install it.

I’m sorry, I don’t know Dutch but this is the description of the program - it might help you to find it correctly:

Advanced Desktop Effects Settings (ccsm)
Compiz configuration settings manager
The OpenCompositing Project brings 3D desktop visual effects that improve usability of the X Window System and provide increased productivity.
This package contains the compizconfig settings manager.

Many thanks rawpigeon,

I’ve added the Advanced Desktop Effects Settings (ccsm).

No more fullscreen Blender and I can also switch to other workspaces now.