Problems with compositing and Shading settings

There is a problem setting up the shadow of my CGI model that I want to add to the camera image on the compositing screen. I can’t intervene in the shadows.
In the tutorial I watched ([] 23:35) I make the node settings in the Compositing tab, but the image I get does not change the shadows and the reflected image is different.

Not: I uploaded the HDRI image but there was no shadow so I put a point light. But I did not remove the HDRI image. If you say it may be related, I will throw the screenshot.

It’s very difficult to see what’s happening here because the nodes are so tangled and some of them point backwards. If you want to composite shadows onto the image you should first enable a shadow pass in the view layer settings and use that.