Problems with Multiplayer Add On from aGoose77 - client don't connenct to host

Like already mentioned in the headline, I use aGoose77’s Multiplayer Add-On for Blender. Because I made already a simple free roam car game but now I want to make it possible that 2 people could compete against each other.
But the Add-On doesn’t work like it should. I can start the server with no bigger problems (only some attempts for attributes). Next I start the player 1 client. But if I start the game and want to connect, It only sends me the message back that the client didn’t find the host. Neither on localhost:1200 or other ports it works. Tried already different blender versions. I use the Add-On version 1.6.5 and blender 2.69. Maybe it’s incompatible, I dont know. Or my Laptop’s ports are closen.

I appreciate your help.

Make sure that the server binds to the address ‘’ (that’s an empty string, not local host) , port 1200, and use the local IP of that computer for the client, and the same port.

Your laptop ports don’t need to be open; your router ports directing to your laptop need to be opened with LAN loopback enabled. If it is just via LAN or crossover (PC to PC) then you need to make sure that your firewalls are disabled and that your IP address and network settings are compliant on both devices.

Thank you for the fast reply.
But No. Still the same. Maybe it’s my pc. For local Ip address I take my IPv4 Address. Firewall is already turned off.

Maybe I’ll try it on different PCs. But now I am going to sleep.
Good night.

Please ensure there server isn’t binding to localhost

I dont not how to change that because every time I start the Server it binds to the empty string ’ ’
server listener ( ’ ', 1200)
server manager ( ’ ', 1201)
I attached a picture from the system console which get when I start the server.

OK. Now it Works. Client and Server are connecting to each other. But after 10 sec I get the message, that player 1 timed out after 10 seconds. And after player 2, too. But I get it work with Version 2.71, older versions aren’t working for me. So my question is:
What can I do against the Timeout? Is it a configuration problem or what? And is it possible, to make a version of the addon, that works in a exportet .exe ? Because then it would be really useful for making your own game. But the question is: Is this much work and I will help or could this work do a single man?
Because I want to do a remake of Call of Duty: World at War’s Nazi Zombie “Theater of the Damned”, only in blender. Have allready the map, mouselook, Weapon etc. But the enemies(Zombies) and the multiplayer addon has to work then (Without timeout). So if anyone would be interested in Cooperation, send me a PM, I would really appreciate that.

The time out occurs because the peer in question isn’t sending data. This usually occurs because no plugins are registered. Sometimes this can happen because the manager plug in which is automatically added becomes corrupted (settings wise). Ensure that you have plugins on the sender object, and none of the plugins attempt to add an object with network logic on it.

Thans for the quick answer again, yes I think I made there something wrong. Thanks for help, agoose77. <br>I already made my “Facharbeit”, practical work for study or school, in a german grammar school. I got a good mark ( B/2) but I work with blender since 4 years. Collected a huge expierence in afterschool teaching and own-study, via youtube and etc. Today I am able to use 3ds Max, Blender, Z-Modeler, SketchUp and other useful software. From autodesk I got the studentversion. Awesome. But Blender is better, because its free! <br><br>Greetings<br>MasterC<br><br>