Problems with texture painting. Weird square shapes . . .

Never bumped into something like this before. When i’m painting textures on some objects, weird shapes appear, instead of textures, when on others i have no problems. Here are some screens :

The biggest problem that i’ve bumped into was texture painted on the wrong side of the mesh, but figured that out with flipping the direction. Now matter what i’ve tried with this one, nothing happens. Doesnt have to be the Normals problem. Now I have applied 1 level of SubSurf modifier for having more geometry to have more detailed UV Layout, that never caused me any troubles before. So i really need your help . . .

97 vies and no one knows? how helpful . . .

You might find people more helpful if you can post a blend file showing the problem.

have figured it out myself. Turns out i haven’t applied scale, so if anyone bumps into the same problem, make sure that scale is applied, by pressing ctrl. + A and selecting scale.

1 Like

I had this problem using Clone Brush, where for some reason Blender was cloning a picture while painting the result on the very same texture. Most annoying.

That big square is the same texture as what is in the middle of your first picture, just to the left of the square, as you say, scaled up.

The second picture looks like its painting the actual UV layout as a texture :confused:

Check your Texture Paint tool settings and make sure you have the correct UVmap selected in the panel.

If it works, that’s great! (But applying scale seems like a strange fix for such a problem. It’d be interesting to know what’s actually going on there!)

Sorry for bumping what appears to be a dead thread, but I wanted to thank the OP and hopefully say something that helps bump this solution when going a google/BA search for the problem I had.

Although it is always something that should be checked, I did not see it listed as a solution in some of the pages I looked at. So, I would like to emphasize that checking and Applying an Object’s Scale (CTRL-A) can be a solution to difficulties in getting Texture Paint to work properly.

I was going to add a new thread asking for help, but I will post it here, both to show a problem that Applying Scale resolved, and to solicit for other solutions or an explanation to what was going on and why Applying Scale worked.

Basically, I was trying to stencil onto my object to make a Mix Mask. Though I had used Texture Paint to perform an identical operation on a different object, it was no longer working. I will post the .Blend file for anyone to look at and offer opinions. In it is only the troubled object (the one that Applying Scale resolved). This object has Scale settings of about .6 for all three (XYZ) axes, and Texture Paint does NOT work until Scale is Applied. Curiously, I was able to paint on an object only moments before and I was NOT required to Apply Scale there. Interestingly to note, though its scale was not 1, but it was positive (1.3, vs. .6). Does having a Scale above or below 1 differently affect how Texture Paint works?

Here is a picture of what happens before Applying Scale. It creates a strange diamond/square pattern, and paint refuses to stick to certain faces entirely.

Here is (if I did this properly) the .blend file:

HelpLid.blend (792 KB)