Procedural Cloudscape Generation in Cycles (now Eevee!)


(Simon Thommes) #21

You don’t have to put my name in the credits in the video. If you do, make sure to add something like ‘Cloud Shader’.
You can also just add a note to the video description.


(Simon Thommes) #22

Honestly…I was thinking about that :smiley: , but I didn’t want to commit to developing this into a professional product. I think this way everyone profits :slight_smile:


(Tibicen) #23

“Nice to credit you”? Man you deserve every credit for that! :slight_smile: There is no way anyone wouldn’t mention you.


(ameen) #24

@Pixelshatter

Can’t see any clouds! What happened?


(Simon Thommes) #25

Try rendered mode
image
Or in lookdev mode try turning the scene lights off and on again, that worked for me
image
Do other collections show something?
image
Does a simple Volume shader show at all?
image
Do they show in an F12 render?

I don’t see any mistake in your screenshot…
Sometimes the volumes wouldn’t render for me, but after hiding/unhiding the collection or going into solid and back to rendered mode fixed it.


(ameen) #26

doesn’t work with any of the changes


(Simon Thommes) #27

meh…
you can try scaling up the boxes or changing the parameters (spread and thickness up, clipping to 1, size mod down), but that shouldn’t be it…
you can also try starting a new scene from scratch and appending the shader
That’s really all I can think of right now… sorry…

What does that give you?
image
If that renders but the clouds don’t… I don’t know, might be something with your setup or hidden in user settings…


(docent) #28

Problem is that some 2.8 build has problems with refreshing node groups- when you ungroup them it start to work


(ameen) #29


@Pixelshatter


(NewVisitor) #30

I also didn’t have clouds at the beginning and then I created a completely new scene.

Cloud-Shader-by-Pixelshatter.blend (1.2 MB)


(Simon Thommes) #31

@docent thanks for the input!

It’s most probably the Blender build then, it’s still in alpha, so that’s not surprising. You can try it with a newer build (or the one I used, don’t know where to get older daily builds though), or just wait a few days. The Beta is soon to be released and I am probably going to update a new version of the shader once that is out.
Ungrouping will probably work (ctrl+alt+g on the group node) but that will lose all Parameters…

@NewVisitor thanks for posting, good to see it working for someone else :smiley: You are using v2.80.29 like me, ameen is using v2.80.30, that is probably the problem


(ameen) #32

@Pixelshatter
Now It works in in cycles in the latest build … But not in eevee


(hernandoramos) #33

I think this should be in included in the next release. So useful. Thanks for sharing man!


(Simon Thommes) #34

That’s… something
I just downloaded the latest build and have the same issue. It’s definitely the build…
Thanks for bringing the problem to the table, but there is nothing I can do about it right now, sorry
Please use an older build or wait :confused:
Bad timing I guess…


(Simon Thommes) #35

:smiley: I don’t know about that, it would still need a lot of adjustments! But thanks a lot, really appreciate it! :slight_smile:


(NewVisitor) #36

Hi Pixelshatter,

you are right.

I just got the latest build, too.

blender-2.80-4e9911663a2-win64.zip 118.58MB Nov 07 2018 01:37:49

GPUShader: compile error:
0(4478) : error C1503: undefined variable “worldNormal”
0(4490) : error C1503: undefined variable “worldNormal”

GPUShader: compile error:
0(4477) : error C1503: undefined variable “worldNormal”
0(4489) : error C1503: undefined variable “worldNormal”


(warnotte) #37

I confirm with that message error with blender-2.80.0-git.4e9911663a2-windows64


(NewVisitor) #38

It’s working again!

https://builder.blender.org/download/
blender-2.80-a421cfa8d31-win64.zip 118.52MB Nov 08 2018 01:30:04

https://developer.blender.org/rBfaecd16d3168981b5af95be613e5a91de5c28133


(tysonhh) #39

Loving the shader. I’m curious is there anyway to freeze the animation of the clouds?


(Simon Thommes) #40

Great :slight_smile: Oh, didn’t think of that :smiley: not exactly right now, but almost:
You can set the time mod value ridiculously low (like -10000)
Then time will pass 2^10000 times slower… that should do it… that is reeeeeeeally slow :wink:
(Pretty sure that number is just treated as infinite by the code)