Projection mapping/ texture mapping issues - Glitch?


I’m trying to work out how to apply an image texture without UV mapping, but I am coming across a whole host of problems. I’ve searched through every forum I can find, but nothing seems to work. I’m sure that what I’m trying to do shouldn’t be as hard as I’m finding it, as it’s very easy and simple to do on other softwares (keyshot for instance).

I’ll attach some images to illustrate my problem at the bottom, but will try to outline the extent of things I’ve tried first, but this is difficult as I’ve tried a great number of combinations and nothing has worked, but I’ve played around with almost every option for each of these in various different combos…

  1. Generated Vector (This is the only thing that achieves the right results in the material preview, but still doesn’t work in the 3d view.
  2. Mapping node (tried with texture, point, vector and normal to no avail, and also tried in various different places on the node chain)
  3. I’ve tried changing all the options under 'image texture
  4. I’ve tried with and without auto texture space selected.

And to outline the issues, just to be clear.

  1. Texture is scaling incorrectly even after applying scale, location, rotation.
  2. Texture mapping direction changes when object is selected.
  3. Texture stretching on at least one axis of object (even when box, or cubic projection is selected.)
  4. Glitchy patterns appearing as you track around the objects

I’ve tried in various different scenes, but the example I’ll show below is with the simplest scene imaginable, just some scaled cubes (with scaling, loc, rot, applied).
What’s more, the texture appears to be correct in the material preview as you can see.
I’ve also tried with auto UV-mapping, but had the same problems, and am very keen to avoid using UV’s as this is not something I have ever done before when using keyshot etc and is unnecessary for the nature of my work.

I’m really hoping someone can help, because I’m really keen to get stuck into Cycles!

Thanks in advance,


No issue here.