Proper edge flow for indent "cuts" for stylised lowpoly with smooth shading

Whats the proper edge flow on “cuts” like this, to look good with smooth shading?

During last days of my game assets workflow learning in between my daily job work i have realised i dont need to learn “how to” and bake high-to-low poly to get smooth curvature map baking result with lowpoly model alone. Only recently i have learned that those smooth/flat settings in blender carry over with exported model. I thought they only affect blender viewport and renders, and everything else is made trough normal maps. Thats fantastic thing to know. However with smooth shading im getting anomalies with this part of geometry.
How should i aproach this? Could someone please point me to some guides dealing with those basics shapes’ proper edge flow? I find all kind of edge flow guides, but cant find anything about things like this one.

Maybe im just to tired like now and my brain cant process simple things, or im just to dumb. Anyhow i have got a huge dose of “revelations” recently related with all these technological things about modeling, baking, importing, exporting, generating procedural textures and unity integration that im turbo-self-learning that i feel like my head is overloaded with to much stuff. I will try again tomorrow to re-do this little “cut” in my model, but in case i wont be able to do it even if i will be less exhausted after work i thought its good to ask the pros.

Pinterest has tons of helpful low poly modeling tips.

And use the bevel modifier.

Thanks Tommy, but bevel modifier is hard to control for me. It creates weird geometry when it bevels concave edges.

Smooth shading uses vertex normals, and on a curved surface which is made out of multiple faces the normal direction is the average between a face and the next one. That gives the correct shading between those edges, but there’s a problem with the flat faces where that curvature starts and ends.

If you bevel one edge of a cube with the profile of 0.5 and enable smooth shading, the smoothing starts between the original big faces and over the beveled edge. Vertices on that edge don’t point to the direction of the face anymore, but are averaged towards the rounded surface. To fix that, you could

  • split the shading on edges you don’t want the averaging to happen, which is marking edges as sharp and/or using auto smooth angle to do it
  • use perimeter loops to limit the averaging on the edges
  • use ‘set normals from faces’ to get the selected faces use face normals on all of its vertices, instead of averaging them on the rounded sides. This stores custom split normals and overrides auto smooth angle
  • use ‘weighted normals calculation’ addon, which tries to get the normals calculated on all surfaces within the object in one go. This is fast and often good enough, but also less precise than setting the normals from faces yourself