Proper Method To Add Bevels To Imported SVG

Hello, I have tried following all the different methods, and none seem to solve my issue. First method I tried leaving (as suggested by a tutorial) the imported SVG as a curve object and using the Curve Object Data to add my extrusion and bevel. It works great except in two specific parts. I have included one here, a letter “T” made in Illustrator. Both image and blend uploaded.

I checked the points in Illustrator and can’t see any issues. One letter I had to “Switch Direction” due to inverted normals (bevel was inside out), but once I did that the top of the letter now was no longer flat (45 degree was now like 60 degree), but at a slight angle. The “T” here is fine, except for one corner, I have tried every option I can think of in the RMB contextual menu and nothing seems to fix it. Tried following several “How to fix bevel” tutorials, and still come up empty.

I tried converting to mesh and followed other tutorials, and I just have too many artifacts for rendering, tried following those tutorials on how to avoid and fix those issues as well. Still, I can’t get what I consider a basic shape to simply extrude and bevel and it’s quite frustrating as I have spent the entire day on this.

Any advice on what I am doing wrong or what else I can try to solve this would be very much appreciated.


SVG_Bad_Bevel.blend (843.5 KB)

Thanks!

-Punker

PS-I searched the “similar” threads and couldn’t find an answer there either.

06:57 SVG Vector File to 3D
http://blender-3d.338.s1.nabble.com/Curves-Encyclopedia-tp1246.html

1 Like

@ozgur1 thank you very much, I am bookmarking that site to watch all the other videos when I have time. That looks like a ton of great information.

Unfortunately, the specific video time stamp didn’t solve my issue. I have followed the exact steps, but the issue still persists. I already tried switching directions from watching/reading other tutorials, it just doesn’t fix the issue with that particular file. I also tried subtracting the bevel depth from both the extrude and offset first.

Are you able to download the blend I uploaded and get it to work? If so I would like to know what you are doing that I am not. For me this hasn’t fixed the problem.

Thank you for replying and please let me know if you have a moment to download and test the file I uploaded.

-Punker

press x > vertices (fix blend file)
fix.blend (838.5 KB)

mesh file
mesh .blend (848.0 KB)

1 Like

@ozgur1 Thank you so much, so it was extraneous points added in by Blender I take it? I verified the problem areas in illustrator and there weren’t any that came up. In Blender I was drag selecting around the entire vertice (corner) and obviously catching both of them so I didn’t realize there was a second one sitting on top of another. I looked for a merge option in case there were extra vertices, and I didn’t find the option.

The curves looked very good in blender so I thought it was something else.

Now that I am aware of this potential issue I believe I will be able to tackle and correct these as they come up thanks to you!

-Punker

1 Like