provide model UV to export to md2 file

Hi
I am newbie here, I have some problems when I try to export from blender to MD2 file. I have the model opened with blender version 2.49. when I select export to md2, the dialog box appears and I set it as follows:
scale factor: 1
MD2 file to save: tris.md2
Frame list to load: default (I need to export a single image)
Texture path: D:\Documents and Settings…\Desktop…ssss.bmp

when I hit export, the following message appears: model does not have UV (face or vertex).

can any one help me in how to make UV for the model?
and how to export to md2 files step by step?

I tried to do the same in the new version 2.52 Alpha 2. But I could not find any button to export to MD2 files. so, does this version support md2 files? and can I export to md2 files? if yes, where is the button and how to use it?

I know lots of questions but execuse my ignorance please, I need an urgent advise to solve this problem.
I appreciate your help

thank you

.

md2 requires the whole model be a single object & everything must be assigned a UV. So there’s something somewhere that doesn’t make a UV assigned to it. Double check. When I had this error I found I forgot one vert.

With the UV window open, go in to edit mode & select the UV verts in the UV window & make sure it’s synced with the 3d window. Then invert the selection in the 3D window & it should show you what you missed.

BTW, the default frame list exports 198 frames (0-197). Use something like Quake 2 Model Editor to remove the extra frames.

Many thanks for help.

I used these information and managed to export something from Blender to md2 file and rendered with OpenGL.

However, I got a strange image.
The model is a sphere with the earth map.

can anyone suggest about the reason and how to get the same image of Blender?
here is the image I got from Opengl:
http://www2.0zz0.com/2010/06/22/23/962311847.jpg

here is the texture I used is here

http://en.wikibooks.org/wiki/File:BlueMarble-2001-2002.jpg[/SIZE][/FONT

And here some information about the model
texture 512x512
number of Textures 1
number of Texture Coords 52
number of Triangles 80
numFrames 198 ( I need onluy one frame only because i want a static image)

what’s the model look like in blender?

in Blender the image is good, it is a sphere with the texture published on the following page page:

I think I got the texture image is 32 bit not 24 bit as my loader expect.
so, can this be the problem ? if yes, how can I convert my texture image from 32 to 24 ? do I need to export the model again and how to tell Blender that I need the image to be 24 ?
many thanks in advance

well, quake2 by default uses pcx, tga & wal format. Wal was id’s format that contained the mipmap versions of the texture. For a model it was pcx normally @ 320x320x8-bit color max. But your own loader can be coded differently, the model just points to a texture, so in reality the model itself doesn’t care.

If you have infranview you can just open the image & re-save it, that app doesn’t support alpha channel saving (annoying imho). The only difference between 24 & 32 bit images is the 8-bit alpha channel. Besides that, they’re identical. I made a sphere & quickly unwrapped, applied the texture, exported to md2 & put in to quake2. I’ve attached a pic, it looks like blender.

Attachments


many thanks

I saved the image with alpha locked and got something better but still the verteces incorrect. I wish to get an image similar to yours.

when I exported to md2 file, a message says: (the image size is not standards 256x 256,) my image is 512x512, I wonder if that can affect
also, when I tried to unwrap, I got the following shape despite that I followed exactly what has been done in a tutorial on youtube about uv mapping, I could not get the same shapes in the tutorial. can this be the reason of my faulty image? I wish if someone is familiar with this case to tell me what to do.

here is what blender shows, it is a sphere and in the uv image editor there is the earth image, I got it after selecting the verteces to unwrap

http://i.iimmgg.com/images/th/3180eec5256848b884a7541a2e34a141.jpg

and here is the tutorial I copied their method.


sorry for the boring and simple questions but I am a begginer
many thanks in advance

And this is the image in opengl:

http://img80.imageshack.us/img80/5800/55211086.png
Uploaded with ImageShack.us

hope any one can diagnos the problem and let me know how to solve it.

many thanks

I found the reason.
it was because I used Icosphere. I had to use UVsphere

strange, that shouldn’t of mattered.