Python Tooltips broken in 2.48a?

Might be 2.48 as well but don’t have that installed right now…

The tooltip string passed to the UI controls (Blender.Draw) do not appear to be showing. Can anyone else confirm this on their install?

I have tooltips here.

Have you tried a reinstall of blender?

hi FourMadMen,
I revise my first suggestion that they are having trouble/lag drawing.
It may be that some scripts tooltips no longer function properly.
I have not fully tested but I can get tooltips most times.
On some scripts however I am unsure if they are working or ?
Is this happening for all scripts or just a few isolated cases?

To put that in English,
Are all tooltips for all scripts not working for you?
Or is it an isolated case?

GAH! The re-install worked. In my own defense I have been using Blender since around 2000-2001 and have not once had to re-install it because something when whacky.

M-A: It was for all scripts that I tried. Not many, 2 or 3 but one day I noticed they stopped popping up.

Sorry for the false alarm. You may now return to your homes.

yes, they need to be more verbose like Zbrush . the tool tips are very vague most of the time, and others it does not exist.
Zbrush you hover your mouse over a tool , and press control, and it will turn the tool tip into a manual page (aka, man page).
They even include diagrams for illiterate people .

Agree, at least on the more verbose tooltips, myself and BeBraw? (I think) - both wrote patches for blender to do this. but were rejected… Because mine only worked with bitmap fonts and I think BeBraws didnt work with translations.
Basically we need freetype (ftgl) to allow word wrap and it dosnt. all this ends up being a bit annoying to do correctly so nobody has bothered.

  • Just letting you know why we dont have multiline tooltips.