Quad core rendering


on quad core cpus is there a way to make blender utilize the whole thing in win7 while rendering? I mean it uses all the cores when it gets to actually rendering the picture, but in the phases before that (that also take up a lot of time) like “building raytree” and “preparing scene” or something like these it only uses one. This on an i7 means it only uses 0.5 cores of the 4, and also means that the 3.4 ghz i7 is not rendering the scene I tested with significantly faster than my core2duo 3.2. (8 secs vs 9, not a lot of improvement). The rendering part is blazing fast compared to the c2d, but the preparing might even be slower as it only uses 12% of the cpu.


Many parts of blender are not threaded and don´t use all cores of a cpu. :frowning:
Often you could increase the render times with changing settings in the Performance > Acceleration structure.
Test Octree for highpoly scenes.

Cheers, mib.

That’s no good, it means it’s a bad idea to go for an i7 from a c2duo, with the c2d at least half of it is used all the time, while with the i7 only 1/8th. :no:
But thanks, I’ll try that.

Not really a bad idea, there are just some things not threaded that way and I’m really not sure why. There are benifits to greater number of cores though. In both cases that same amount of prcessing power is used for the initial part of the render, but the duo will be left behind by the hypertheaded quad core when it gets down to business.

Well, after some testing I have to say, you are partially right, the rendering is faster, but not by as much as it should be, however blender in general is slower, a lot slower. I tested the same scene, that my C2D handled fine, on the 2600k (which has twice as much ram as well) it becomes pretty choppy to even move the view around. It can’t handle the polygon count as it only uses half a core of the four. :frowning: Isn’t there a way to make an app see all the cores as one, or at least to turn off hyperthreading, but only to blender, but leave it on for all the other applications (1 core is still better than 0.5)? Or maybe a build that behaves differently?

I have had the same prob/question. I have a quad core AMD cpu and it renders quickly, but building raytrees, etc takes time.

I just disabled Hyperthreading, and well, as expected, Blender has about the same performance now as with the C2D, it is much faster then it was with HT enabled (I don’t really understand this, I thought HT was supposed to make it use a whole core if it only has one thread, but it’s not how it seems). As for rendering test scene was done in 27 seconds with HT enabled and 28 with HT disabled. The actual rendering part is a lot slower, but everything else is a lot faster and it pretty much evens out, but might be a larger difference with a more complex scene. I suppose if I have to render a long animation I’ll just reboot and turn HT on for that.

If I set process priority of blender to above normal or higher I can get almost the same performance with HT on as with HT off, but better render speed (23 secs on the same image vs 28 with HT disabled).

Depend of the scene you could increase the threads and tiles settings in performance menu.
With i7 it should be minimum 8 threads with HT.

Cheers, mib.