Quality of rendered sprites (2.8)

Is there any way how render sprites in Blender 2.8 in same quality as 3DSMAX scanline render? I tried almost everything in render settings, but Cycles is physically based so I can’t get nothing closer to scanline output, freestyle is for cartoon graphics.


  • blur (pixel filter, I’m using Catmull-Rom in 3DSMAX)
  • weird sharp edges/lines
  • poor details


(1:1 and 2x zoom, ligths in Blender are bit off but it has no effect)

Welcome. Pic is from 2.7 but the settings are in 2.8 IIRC, just search for the Sampling and Film panels. Play with the AA and Width settings to see how they affect your renders, adjust to taste from there. If you’re using textures you could set their Interpolation to Closest too. Enjoy, and share some results please.

Hi, thank you for reply. I tried suggested settings, but result is almost same. Only pixel filter with width around 1 is able fix sharp lines (long pipes). Physically based/ray tracing renders are causing lot of noise, scanline works differently, also catmull filter is better. I will try more, because Blender 2.8 is better than 3DSMAX, then I’ll show the results in case of improvement.

If someone is interested, here is blend file: http://pasteall.org/blend/index.php?id=51604

What about this?


Just went to 1.40 blackman filter radius and set integrator to path tracing, with 512 samples.

Also switched to Filmic with high contrast.

Unfortunately it’s too blurred. I’m looking for older art style - Age of Empires 2, Fallout 1/2, Sudden Strike where are sprites rather sharp, which fits more with whole 2D scene and it’s more decent for the eyes.

Then filter around 0.7 is more acceptable.

Could you try doing this in eevee? You might get more of the scanline look, and lose the blurring of multibounce lighting.

Though if you are sticking with cycles, you could try reducing the number of bounces, that will get your closer to the original style.

This is my attempt rendering it 4 times bigger and scaling it on gimp.


Edit: And this with a bit of AO.


@SterlingRoth - Eevee is not suitable for these purposes I think, all the details are out. Ok, I will try bounce settings.

@Asticles Good idea, details are fine. With some decent resampling formula it can work probably.

I used Linear, in this case. But you should try with others.

Also, your lights have a huge radius on them, so you are casting very soft light on your object, which will wash out the details a lot.

Try reducing the radius of your lights.

1 Like

@SterlingRoth - You’re right, object needs some volume. Btw. I found that lights are causing these sharp edges on pipes (esp. sun). I must fix it first, also AA vs background if it’s possible.

@Asticles - Downsizing isn’t right way, it’s too blurred or it looks like same as output from Blender.

Try bounces 0-2, also get to lamp settings and disable cycles visibility for direct and reflections.