Question about a new texture plugin...


(Nishi Acolyte) #1

Hey all, i’ve been trying to add some good looking hair to my 3d head, and i’ve been trying to use a technique called billboarding. I noticed that when i apply alpha to my polygon it works fine on the plain world background, but if there is an object between the background and the polygon then it makes the object in between transparent. I was wondering if there was already a billboarding python texture script, or if there are any suggestions on how to get started on writing one. Thanks for your help guys.


(Fligh) #2

Do you have ZTransp on for the alpha polygon? If so, then use the ZOffSet option to the left of it.

%<


(Nishi Acolyte) #3

I tried using the ztransp option and turning up the offset to 1.0 from 0, but nothing really worked.

I have a color map with alpha attached and my settings are:

alpha = 0
Zoffs = 1.0
Texture is mapped with Color, Specularity, and Alpha

I have the use alpha turned on in the texture window, so i know that’s not the problem.

I don’t get it. I think what’s going on is that in Blender, as far as i can tell, billboarding only works when your using it against the world background and not with mutliple objects in between. Is there any way to fix this?


(Fligh) #4

No, Blender can do it. You can do a forrest of trees.

Send me the file ([email protected]) with textures packed (File >> Pack Data) or upload it and I’ll take a look.

%<


(Nishi Acolyte) #5

I can’t seem to find where the add attachment is on the reply form. If you could give me a little help i will try and post the picture i have of my current problem.


(theeth) #6

He meant send it to him by email.

Martin


(Nishi Acolyte) #7

Well…i seemed to get the billboarding technique to work with a new sample blender file, but it remains to be seen if it will work with the hair technique i’m trying to use on my head. I will try out the zTransp and RayTransp techniques and then post some replies.


(Nishi Acolyte) #8

It didn’t seem to work too well…the problem is that, while settings the zTransp option to on will make the polygon transparent, it darkens the mesh behind it too much.


(purple) #9

I think this techneque is also know as the cards system for hair/fur - much employed in Ice Age.

If I am right you might find it very useful to look at the Beast python script.

I think you need to apply 'transp’arancy to your polygon texture not alpha - then the ray shader options ztransp etc should work.


(Nishi Acolyte) #10

Where is this transparency option that you speak of? Alpha is used to determine things like transparency and bump and keying, so other than Raytransp and ZTransp i don’t see any button to do with transparency. Thanks for all your help guys.


(Fligh) #11

In F9, Material tab, bottom right, sets the transparency of the Material.

In F5, MapTo tab, top, second row, texture mapping option.

In F6, Image tab (when using image) top row, Use/calc/neg alpha.

Recent post:

http://www.elysiun.com/forum/viewtopic.php?t=55051

%<


(Nishi Acolyte) #12

Yeah i’ve been using the alpha buttons mentioned in the above post, however it never really seems to cut out the sprite from the image. I’m really impressed with the tree example, this is what i’m trying to do with the hair on my model, so maybe i’ll try and examine the tree post and find out the secret to this technique. Do you guys know of ways to do hair using the new curve deformation options mentioned in the blender 2.40a release logs? They show examples of what hair can look like with curve deformations using particles, however, i haven’t been able to implement it yet. Any ideas?


(Fligh) #13

You probably need a later Blender build.

%<


(purple) #14

Sorry Nishi - what I actually ment was 'translu’cency on the texture ‘map to’ settings - and I think I was wrong anyway :expressionless: Alpha’s the setting you need.

Fligh %'s email should be the resolution to your problem.

RE: Cutting the sprite out of the image - What image format are you using? I have used TGA created with gimp and I have got good results.

This might also inspire/help http://www.elysiun.com/forum/viewtopic.php?t=16008


(Marty_D) #15

Did you, on the Shading panel (F5), turn “TraShado” on for the material on the mesh behind? Also turn TraShado on for the hair material as well (under the Shaders tab) for self shadowing. And “Ray” is on for the Scene (F10)? Even if you’ve set Ztrans you still want to use ray tracing to cast individual fibers. This technique has worked since ray tracing was built in to the soft and usually the problems you mention are due to the above going missing somewhere. :slight_smile:

Translucency is a method of allowing light to show through a surface color. Alpha is the setting for transparency. As mentioned above.

You can use negative alpha settings in the material but that will affect other settings too and if you’re sharing the chanel with, for instance, a bump then that effect will be influenced too. Better to turn alpha down all the way on the main setting and use the hair map to add alpha in order to make the material visible.

You’ll probably see all these in the example blends anyway. Had to talk or explode.


(Nishi Acolyte) #16

Well guys, thanks so much for all the help you’ve generously provided. I finally got my hair working by turning on the traShadow option and experiemeg with the translucency settings. I often find it’s one thing that is out of place that can decide how an entire scene looks. Thanks again for all your help and i’ll be sure to stay on the forums and try to help out like you guys helped me Later!