Question on layers rendering

Hi all :slight_smile:

I have a pretty heavy scene set up for rendering. The main render hit will come from hundreds of trees made on 7 particle systems with transmapped leaves.

I was wondering whether there is a method to put the particle systems on layers to help the rendering along, or will I first have to convert them? If I do convert, won’t that take a really hard hit, cancelling out the advantage of layer rendering?

Hi everyone :slight_smile:

Never got a response from my first question, so went ahead and converted the trees, put them on layers. Now I have another problem I’m oping someone can help me out with.

As a test, I’m only rendering the background, the road and two layers of trees. Problem is, it renders the background, then the road - so far, so good, then does two renders of just the background, where those should be the two tree layers.

It looks correct in the 3D view. Next problem is I can’t access the compositor - nodes don’t show and all input/output node selection greyed out.

Hope you can see what the problem is from the pics - if not, I can post the file, but it is pretty large.

The forum won’t allow me to upload more than three pics, but the settings are more of the same.


For the first problem, I’d assume you got the layers mixed up - double check if you’re using the right scene layers in your render layers.
For the second problem, the only thing I can come up with is that you may have accidentally removed all of the nodes, if that’s the case, you just have to readd them.

Thank you for responding - you are correct on the first problem. Got a little confusing there, but now I have discovered the render layer manager, should go better in future:)

A secondary problem was that a whole swathes of trees were inadvertently hidden from the camera. No idea how that happened; I would certainly remember doing that a few hundred times.

The second problem was fixed by accident - I clicked on the icon next to the compositor icon, clicked back on the compositor and the nodes came back - hooray!

Something that has really had me tearing my hair out all afternoon is that the layers render correctly, one after the other, but when the last is rendered, they are all overwritten by the first, even when rendering each layer separately. I have another scene with the exact same settings, as far as I can tell, which works perfectly. Even have file output nodes attached so that each layer can be saved for external editing.

A clue as to what could be wrong is that the previews of the renders do not show up in the nodes and the viewer is empty. I’ve compared the settings of the two scenes and can’t find any difference. Any idea as to what could be preventing the renders from “taking” in the nodes?

One more question, if I may. From what I understand from watching many vids, it appears that compositing is a once-off process. No way of saving as a project file to continue working on later?

Why I ask is that if I have to let a render run overnight, I don’t have time in the morning to finish compositing. Would like to be able to save, close and come back to it later.

Even though I get the feeling I’m talking to myself, I’ll give the solution, just in case someone stumbles across this:)

For the first, you have to render something - anything, even just one layer, to grab the compositor’s interest. Can’t set up a compositor node system without a render!

For the second problem, I discovered the magic of OpenEXR - that is truly amazing! Set up layers, do the render and save as OpenEXR. Close down if you wish and come back later. Do a re-render, which takes seconds and you are good to go.