Radiosity in game engine???

I see in this game: Walkthrough demo, and Radiosity; that the room is textured with radiosity method, how do it???

im not 100% sure but i think they render it with radiosity then uv mave the rendered images to the low poly mesh

Yes you can. Use the old radiocity options, not direct render, but caculating with the radio button :slight_smile: Afther that enable texture mode and press p :smiley: You’ll see it, but rember radiocity ads vertices, so keep this low or it will really lag :frowning:

  1. i create the room and object;
  2. i set the material for all object
  3. I go in a radiosity windows, Collect Mesh and go.
  4. The calcolation has finish.
  5. NOW???

When i press “P” all object is white, isn’t textured :frowning:

Well the radiocity is done, but you have to push a button to convert all radiocity to vertx painting. I tought is was 1 of the 4 buttons next to Collect meshes, also not free radio data. try another 2. I can’t test hre no blender on the pc where I’m at now. (work) But it should work. You have to stick the radiocity on the meshes to mae them visible in realtime. :smiley:

  1. collect meshes
    1.5 [optional, but you probably want to] change settings
  2. GO!
  3. wait
  4. press esc if impatient, it should finnish on its own but that may take a while
  5. press add new meshes [leaves the old one in case you want to do this again]

and that’s about it

the lighting is stored in vertex colors

making these meshes sensitive to dynamic light isn’t very useful

it is a good idea to reduce the number of polygons in your radiosity solution [so it is faster and easier on the user’s computer]. To do this, turn up the min and max sizes for patches and elements. These are based on the size of your radiosity calculation, so if your world gets bigger they will probably need to be tweaked again.

subdivision shoots should probably be at the default settings

read about how everything works in the docs:

maybe not obvious, at least for me, took a while to figure out: this radiosity baking function (shown as the radioactivity button in the buttons window) doesn’t take usual lamps into account, it needs objects with light emitting materials.

Just a note, radiosity normally subdivides the mesh a lot, but if you set “Max El” to 1, (not “ElMax”) then it won’t subdivide at all. (It doesn’t give as nice results though.) Try experimenting with different values for El Max.