Radiosity - meshes dissapearing


(Keithkosh) #1

I am having a lot of trouble with Radiosity. I can get the actual process to work fine, and get nice shading and whatnot. But, when I go to Render with F12, Blender leaves out about 90% of my meshes! They are there when I am editing them, clear as day, but they don’t show up in the Render, and this is just after I have used Radiosity. I thought it was my version of blender, so i tried the same file, which was my computer desk, at school - the render after Radiosity ALWAYS only rendered the wall and mouse button and NOT the tons of other meshes in the same scene, like the desk, monitor, etc. I have no idea how to fix this - the model is at http://keikorner.cjb.net/computer.blend if that helps any.

And by the way, I have also already tried moving everythign into one layer before I use Radiosity. It doesn’t make a difference - some meshes are simply not showing up for me after radiosity!

Keith


(TurboG) #2

Ermm…I can’t find any missing meshes…Render it. Press Control+Printscreen. Go into a Photo editer thingy and Paste it. Circle the problem area. I don’t see a missing mesh…


(Keithkosh) #3

sorry the images are really bad quality, but i saved them in gif format using Paint…it was the fastest way anyway =p

http://members.shaw.ca/keithkosh/normalscene.gif
normal scene, rendered as-is exactly as the file was.

http://members.shaw.ca/keithkosh/wheredidputergo.gif
Pretty much self-explanitory. This is rendered After I do a default round of radiosity (leaving all settings as in from the file) - and of course, click on Replace Meshes after the radiosity finishes. i know, i forget to get rid of the default lighting, so it doesn’t look like radiosity even happened, but I just did it once and didn’t bother to edit the lighting or anything for sake of example.

So, should I add a circle? hehe :wink: WHY WON’T IT SHOW???

Keith


(BgDM) #4

you can not have any sub-surfs in your model when you do the radiosity. you need to convert everything to a standard mesh using “Alt+C”. Then delete the subsurf portion, (cause it converst and savesa copy). then after you have doen this, rerun the radiosity again.

Should solve your problem.

BgDM


(Keithkosh) #5

Thanx! =D -Keith

[Edit]

No wait, it’s not working! The parts that are showing up, some of them are not SubSurfed. I have another model where the head won’t show up, and it’s not even Subsurfed! The hair is Subsurfed, and it does show up! Maybe it has something to do with the Auto Smooth, or something?..


(rivenwanderer) #6

Don’t know if this will help or not, but have a look at my struggles with radiosity… I’m not sure exactly if I’d explain it right so I’ll let you read Theeth’s explanation :slight_smile: