Random color for Particle Instance

Hello,
I have a simple scene with Particle System and Particle Instance.
When I try to randomize color for Particle Instance it’s nothing happen

Sorry if it simple question but I realy cant understand what is wrong.Some_Thing.blend (749.9 KB)

You have to use the particle info node instead of object info.

The same with Particle Info

Particle Info only works in Cycles not in EEVEE. Perhaps that´s the porblem.

No luck here too

I’ve never done it with particles, but dupliverts works fine for me.
I would also change the wireframe modifier approach to; delete faces only from the mesh, convert to curve, and give it geometry/bevel for thickness. If you want random from random, use a 1D white noise texture going into hue. The random output doesn’t have the correct distribution.

1 Like

Perhaps it doesn´t work with particle instance.
However, you could just use particles directly:

1 Like

With Particle Instance it works a bit different. You have to add vertex colors layer (could be any name) and link it inside shader:

4 Likes

Can you explain how do you get this in details. Thanks.

Use your object - the modified icosaeder - as emitter.
Set the number of particles to the amount of vertices the icosaeder has.
Set start and end frame to 1.
Set emmit from to “vertices” and turn the “random” checkbox off.
Set physics of the particle system to “none”.
Use a sphere as particle object.
Give this sphere the material with the particle info node.
Give the icosaeder a wire modifier.

1 Like

Thanks every one for so many solution. Tried all of them and learn a lot!
For my first scene I abandoned Particle Instances and used this settings:
as Lumpengnom suggested but with a little change

  1. Used emitter instead of hair
  2. Render as Object with scale 1 (Instance Object - Sphere)
  3. And the last in Extra turn on Unborn.

And magic happen - all random colors with old material settings.
Didn’t change number of particles and end frame, didn’t turn off random checkbox, didn’t change physics of the particle system.


And as bonus it can play animation with very high FPS

Do you mean “hair instead of emitter”?

Sorry for my mistake, english not my main language.
probably needed to write
“Switched to emitter instead of hair”

Interesting. My setup was with an emitter, too. If you use emitter and did not change physics to “none” why are the spheres not falling down due to gravity?

Because I turn on “Unborn” in “Extra” menu, and they are falling if I play animation, but on static 1 frame they are all in start positionSome_Thing4.blend (754.0 KB)
and Yes, you can change physics to “none” if you don’t need animation

Ah, I see.
If you do not change the amount and have unborn turned on then there are multiple spheres on top of each other. You might want to avoid this because it can lead to problems like z-fighting:

1 Like

Have this when I turn physics to “Boids” but ok with other even if you set to “none”
look at the file that I attached earlier


maybe I do not quite understand this
Add: Oh ok, cycle render have this issue, eevee is fine
good to know for future, thanks!