Realistic Water Help

So I decided to do some quick water renders (because they are easy, fast, and look awesome :P).
I get my water all nice and dandy…and it’s this ugly grey mass…

Sure, it looks great, it simulated fine…but it’s just this grey blob.

I poke around online looking for some realistic water, and I found something that suggested that I use a glass material and set the IOR to 1.333.

Well, it still looks like ugly glass. I want a water material/texture/anything that makes it look like real water. I had something like this in mind:

Any idea how I can achieve this?

You need something in the environment for the water to reflect and refract. If you’ve just got water on an empty grey background it will never look realistic.

Any suggestions as to what I can use?

Um…whatever is appropriate for the scene you’re trying to make?

If you just want some kind of background to reflect, there are tons of free HDRI images around the internet that you can use as environment maps.

I’m just trying to do a high resolution picture of a drop of water coming down (like a frozen in time photo), no scene. So I’m not sure what to look for.

What kind of environment is this drop of water falling in? Is it a raindrop outside? Is it in a room? Is it in a cave? Is it on the moon? Find an environment map that matches the scene. I can’t tell you what your scene should be. You’re the artist here.

I suppose…I had just a “plain” background in mind but that really wouldn’t reflect much.
Perhaps I"ll angle for something more “nature” like.

But I want to know, will adding a nice reflecting background cause my water to look like the water in that video? He didn’t have any background.

Sure he did. He had a whole room with what appears to be mesh lights, a pipe, a table, a glass tank… If you just have a drop in empty space with nothing else, the quickest way to get an environment is an environment. Or you could model some stuff like that guy did.

Well I’ll try some more regular stuff first and if it still doesn’t look good, I’ll try a bright environment.

Look at the difference between these glass icospheres with environmental lighting and without. Then get over to
And download some nice images. The ones I’m using (and post a quick link to) are just thumbnails, full res or hdri will look even better. Horseman is right, Fact: Water needs something to reflect to look right.

Just go to your world tab, choose environement texture, and toss this low res image of malibu in, and then go to the link above (or countless others) and get yourself a stash of hdri images.

This preview image of malibu is from an image pack at

Thanks for the help, but I really got what I wanted when I made the material color slightly blue-ish.

Thanks for the tips though.

I’m sorry, I kinda have to reopen this thread. I don’t really want a background, I want a better water texture/material.

My water still looks like glass and when I render it in high quality it doesn’t look like real water.
I need a better material or a texture or something.

We’ve explained why your water doesn’t look good, and you’ve chosen not to follow the advice. Dunno what else to do for you. It might be worth noting that you can use an HDR for reflections only, if for some reason you want to keep a blank background.

Anyway, you keep saying you want a better material, but you haven’t even bothered to show us what you’ve already got. What do you expect us to do?

I already explained this to you. I’m using a Glass material with the IOR set to 1.333.
I already told you that. No need to get sarcastic. :stuck_out_tongue:

Is there another way I can make a material that looks like water? (Or is a texture a good idea?)

BECAUSE, when I use this current material, it reflects very very weirdly when I use a background.

Post the blend, it’s probably something relatively simple to fix. pasteall, or dropbox, or just upload as an image if it’s small.

Telling me you have a glass material with an IOR of 1.333 doesn’t tell me anything else about your setup. I’m not being sarcastic. I’m trying to help you and you’re not taking the help that’s offered. Post your .blend file and we’ll see what we can do.

Water Test.blend (592 KB)

Tell me if this works, I’ve never uploaded a blend file before.

I’ve had a look at your .blend file, the image you need to use is the .hdr image, not the .jpg.

The world texture type also needs to be an Environment Texture, rather than an image texture.

The plane that the fluid is landing on shouldn’t actually intersect the plane when its being rendered, just move it down a tad, its a limit due to the resolution of the fluid simulator.

Finally, I’m getting an issue with the normals when rendering, the ones that have hit the bottom actually have the normals pointing inside rather than out, and so the glass shader isnt redering correctly. This issue is caused by Blender’s fluid simulator, I’m not sure how to fix it really. If I convert the fluid sim (single frame) to a mesh, fix the normals (recalculate in edit mode) and follow all advice I’ve mentioned above, this is what I get:

I was aware of the environment/image texture. I used the image texture because it gave me better lighting then no texture at all, and I was getting horrible renders with the way my material interacted with the background. And you say “The Plane shouldn’t intersect The Plane”…I’m confused. Perhaps it’d be easier to delete the plane.

And forgive my noobyness again, what is a normal and what do you mean it’s pointing the wrong way?

Anyway, the picture looks really nice, except for the checker pattern. But really what I was trying to do was ditch the glass material entirely (unless it could be fixed) for a material that looked better.

Sorry, I meant the plane shouldn’t intersect the fluid for rendering :slight_smile: My bad!

Each face in the 3D world has a ‘normal’ which basically points to the ‘outside’ of a face. Unfortunately, the mesh the Blender FLuid Simulator is generating has normals facing the wrong way, so parts of the fluid are being rendered as if we are looking from inside > out, even though that is incorrect. I’ve tried changing settings to fix this, but I don’t know how :confused:

The checker patter was a random pattern I added to see something underneath.