Recalculate normals is wrong

I have a mesh. His name is bob. Bob is manifold. I press ctrl-n. Bob is inside-out. I press ctrl-shift-n (recalculate normals inside) and it calculates them outside. Grrr. Something must be wrong with my mesh. And bob has a hundred brothers. They are all inside-out. Can you help bob? I have applied his scale and rotation.

Ctrl-A your object

then show all normals in F9

select one of the wrong normal
then Shift G select normal
this should select all the wrong normal
then flip them in F9

if not then select manually all the wrong nornal and flip then

that’s always a problen with non manifold faces

that should do it


I know my mesh is manifold, without a doubt, because ctrl-alt-shift-m doesn’t select any edges. I also know I can flip the normals to fix this, but recalculating the normals outside is doing it wrong, and is performing the exact opposite action. This must mean there is something wrong with my mesh. That’s what I’m trying to find out, not how to make the normals point the right way. It’s just that ctrl-n usually gets it right. I’ll also have to find all faces with inverted normals and switch them manually, which is a pain if I don’t find some.

have you check if you don’t have any doubles in the mesh ?

may that’s it

can you show the mesh in edit mode

non-manifold always giives problem with normal


Picture 1.png
No doubles. It’s manifold, and simple.


Here’s why i don’t want to do it for every mesh i have:
Picture 9.png


Do any vertices show up?
Otherwise at the bottom of this page ( ) is a script for Unusual Non-manifold search tool

No vertices show up either…but it’s an edge-only tool. and besides, can an isolated vertex be non-manifold?

Post the .blend.

Someone should be able to help with that…

Look like you might have introduced a twist in the mesh, turning it into the equivalent of a klein bottle. Turn off subsurf and take a look at how everything is connected. I suspect you’ll find some warped quads in there.

It may be hard to tell from the terrible pic, but my mesh is pretty simple, it’s not a möbious strip, it’s just a simple loop made of quads.PieceOfSh.blend


PieceOfSh.blend (131 KB)

Turn of the subsurf modifier and you’ll see that your mesh cuts through itself, thereby making it non-manifold. That’s why the normals are calculating weird. You’ve confused Blender with a self-intersecting mesh.

faces are criss crossing each other and the renderer does not like this

see pic

so change that and it should work fine


Oh… I thought any mesh with no edges that have more or less than two faces as users is manifold… but obviously self-intersection counts. Thanks, I’ll try to remember this.