Reconfiguring the mouse on 2.79b

Can someone guide me to re-configuring the ".79b to use:

LMB: select
RMB: rotate
shift-RMB: pan
scroll wheel for zoom
MMB: context menus

I found User preferences, Input tab Select with Left.

But got lost in Screen/2D view/"d view Buttons list/3D view for the appropriate place to change

rotation to the RMB, and context menu to MMB; and shift-RMB for Panning?



if it can help you …

Thanks. That seems to have given me most of it. (Still looking for context menu?)

One small thing though; the Zoom View option is somewhat deceptive. If you try to change it from “Crtl Middle Mouse” to scroll wheel by clicking and rolling the wheel, all sorts of weirdness ensues. I know, “So Don’t Do That!”.

Restore and start again.

Or rather…it did for a while. I was happily rotating and panning the default cube using RMB & shift-RMB just as I wanted.

So then I delete the cube, go into top view ortho; draw some stuff, get to a point where I need to alter my view point to be able to select some nodes and press RMB to rotate the view and …

All that happens is the 3D cursor jumps to where my mouse is when I click RMB.

I quit out and restarted Blender and now RMB moves the 3d cursor even for the default cube :frowning:

I’ve been back into User prefs, and everything is still set:

(I would have cut that down but I can’t find an application (installed) that will let me.)

I tried searching for a key binding that looked like it might be moving the 3d cursor, but none of them look likely to me?

{image of key-bing search deleted - new user 1 image only}


keep calm . . . :wink:

You have a conflict between two actions:

Rotate view = RMB (right mouse button)
Set 3D cursor = Action Mouse (which also corresponds to the right button of your mouse)


For you, is the contextual menu the one obtained by the W key ?

In truth, I don’t know :slight_smile:

My thinking was that since the RMB is normally used (in most applications) to pop up context menus relevant to the position they are clicked, and I am re-assigning the RMB, and freeing up the MMB, I would swap the “context menu trigger” to the MMB.

But whilst the RMB brings up context menus most places, it doesn’t seem to do so in the main window, so perhaps its not necessary there.

Or, maybe it did before I reassigned RMB?

Truth is, I paranoid about changing anything now I seem to have something I find usable in case I screw it all up again.

For example: I thought that I would remove the “scene” menu on the right, as I am not using it, so I clicked on the diagonal lines (as I saw in one of the videos and attempted to drag it away. Instead, it gave birth to a copy, and when I tried to drag that back again, it birthed another. I tried right clicking in various places, but the doesn’t seem to be a “remove this pane” option anywhere.

So (again) quit out and restart and hope that it doesn’t remember my c***-ups.

If you’re new to Blender, don’t worry. . . it always takes a while to learn. :wink:

If this is the case, and unless you have special constraints, why not use the latest version (2.82)?

You will see, with this version, the right click to have the context menus works perfectly … :+1:

Under 2.79, if the right and left menus of the screen “bother you” you can switch to full screen> ALT + F10 (toogle)

And do not forget, first read the documentation.
Most of your questions will be answered …
Blender 2.82 Reference Manual

I’m currently in transition between my old machine running windows and this new one with Linux.

2.8x will not install on the old machine – Direct X is too far down-level – and what with trying to get to grips with Linux and blender – and frequently retreating to the old familiar environment when the frustration level gets too much – adding two (apparently quite different) versions of Blender into the mix of stuff to learn just seems masochistic at this point.

The 2.79 manual is open (>>>next tab along) but there is a lot of it, and it is not always obvious where in the manual I should be looking; it is very easy to disappear down the rabbit hole.

I’m currently on a high having (at about the 10th attempt) succeeded in modelling a pair of bevel gears; albeit by essentially single-stepping a tutorial video.

So, I’ll back off from this place for a few days and let you get some peace.

Thankyou! Much nicer!

I was hoping to keep the structure tree on screen as that is useful to me. But its only an Alt-F10 toggle away and I appreciate the greater screen space.