Reducing complexity: Curve to Mesh conv.


(mattpegg) #1

Hi all,

I am getting a “too many vertices” error when attempting to convert an Path object, with an extruded nurbs circle, to a mesh object.

I am surprised at this given that the Path object is not overly large, and the Nurbs circle is simple.

Is there a way to reduce the complexity of the conversion, when going from extruded curve to mesh (ALT-C) ?

regards,
Matt.


(BgDM) #2

How long is your Path? I usually use a bezier curve to do the BevOb function and then convert to a mesh and then finally, to a subsurf to smooth it out.

If the path is too long, then you get the error. You can change the path length in the animation screen.

Hope that helps.

BgDM


(ectizen) #3

You can also try adjusting the DefResolU setting for the curves, found in the edit buttons (F9). This controls how many straight edges are used to approximate the curves.
For example, with a default bezier circle, changing DefResolU to 1 and pressing Set, makes the circle appear square. Changing it to 2 makes it octagonal. Increasing this value increases the complexity, making the circle smoother.

Depending on how much complexity you’d like to cut, this can be applied to either the nurbs circle, or the path, or even both.

I think the default value for this is actually 12, not 6 as the edit buttons seem to imply.