Reflecting bump maps...

It appears that blender can’t reflect bump maps. Reflections of bump-mapped surfaces appear grainy. Is there a way to make the material reflect the surfaces without bump maps, so that I don’t get the graininess?

i think you need 2 maps here
one for the bump
and another for reflect map
then you control every aspect of it

happy 2.5

I think you’ve misunderstood me… The reflective object is a second object (not the bump-mapped one). As in looking at the bumpy object through a mirror, if you like. I will post an image to clarify tomorrow

sorry misread!

did you add some mirror values show pic to see

it should work fine in approximate render not raytrace!

there was a similar problem a few weeks ago!

happy 2.5

may be this can help

i’m trying to get the thread for this mirror thing

happy 2.5

Is the bump map not showing in the reflection or is it showing, but is really grainy?

If the first, then you should use the new bumpmap algorithm present in 2.57 and 2.58, and no, this isn’t the original new algorithm, but the new, new algorithm (sparkybump and it’s higher quality 5tap option)

I am using the newest algorythm, and the bump map does show in the reflection but it’s grainy. Here is a shot. I haven’t came up with any solutions so far.

EDIT: I changed the bump method to the old algorythm, and now bump maps do not show up in reflections at all. This is suitable for my case, but I’d like to see the problem solved :slight_smile:

load up a sample file so we can take a lookat your settigns!