Reletive parent to bone moves my object

my object has no parents but when I parent it to the bone relativly my object (eyeball) moves and jumps back.

Object has a Damped Track Constraint.

Yeah, sometimes Blender screws things up when you parent. Was it parented to anything before? Undo the parenting, unparent it->keep transformation, parent to head bone relative.

Still not working? Undo, snap cursor to selection, parent to head bone relative, select eye, snap selection to cursor.

1 Like

your solution works (many thanks to you!) but with a twist. now when I do eye tracking with Damped Track Constraint the eye rotates in place like crazy!
when I turn off the Damped Track Constraint eyes are looking like this:

the rotation is 0

1 is what it should look like with 0 rotation
2 what I get with even 0 rotation.

ok I’m thinking this is a bug. so here it goes: doing it with the keyboard shortcut causes this BUT if you go to relations and set it manually it works. This is stupid.

Sometimes adding constraints with ctrl+shift+c messes up the target object, chooses another random object for some reason. Is this what happened ?

Probably what happened is that the eyeball ended up rotated the wrong way, but didn’t notice because of the damped track. Mute the damped track, rotate it appropriately (maybe just apply rotation), re-enable the damped track if it happens again.

(Sorry Hadriscus, I thought you were Weekend.)

Track was off and rotation was clear 0.
Well it’s now solved for me so thanks for the suggestions.