remove basic gl shader in glsl mode

So I’ve been putting this off for a long time because it hasn’t been bothering that much, until I started planning to write blender game engine patch ideas in my head, but that will be for another thread.

Anyways when GLSL mode is enabled it still leaves that big dark shading on the faces that are not eliminated from the light source. Is there a way to remove it and just let GLSL to do all the work? I don’t care if i have to edit the source. As long as it’s for the better.


Not sure what you’re talking about - what “big dark shading on the faces that are not eliminated (illuminated?) from the light source”? You should use a couple of Hemi lamps to raise the overall lamp level to make things brighter.

I was hoping to save this model for a later thread since it’s a W.I.P…

anyways this really sticks out using the sun lamp. just even using a mulch-texture mode this happens. on one side it is lighted perfectly, however faces blocked by the light end up pitch black. GLSL would just darken the aria slightly.

this is what i’m talking about.

This is the Shading… it’s not? If you don’t want a complete black shadows you have two good global options.

  • Add a Hemi lamp
  • Configure the Ambient color of the world

changing the ambient made thing more colorless and adding a hemi lamp made the glsl shadows pitch black instead of natural like the image above. I’ve played non blender games that have the exact issue. so this isn’t a blender problem, this is an opengl problem.

Man i have no idea what you’re talking about :confused:

I think you’re confused - Multitexture doesn’t darken the area significantly, while GLSL actually does more accurate lighting (i.e. one directional light, no other, ambient lighting, and the sides facing away from the light will be dark).


Yeah, ambient color just tints the overall colors, not increase the overall dark levels. It would be nice if it did, but it doesn’t.


In the image above, the shadows are pitch black. And using a hemisphere lamp lightens the color of faces that are within 180 degrees of the light’s rotation, making things overall brighter.

I think that you might have a problem with your graphics card (like it not supporting GLSL). What kind of card is it? Have you tried updating your drivers?

Vitor:yea… that a thing when you talk with me, i suck at explaining things… and i was referencing the image of the front of the spaceship. sorry about that…

Solar:i didn’t do the 180 rotation on the hemi light, that’s why apparently it looked weird. and thanks to that, it’s fixed and it leads me to another question… Why isn’t the hemi shading trick implemented into the sun lamp code when variance shadows is turned on? because now it looks alot cleaner and more realistic, and as a bonus, it’s not affected by objects which makes it better/more helpfull. oh btw: GPU is nvidia 740m with beta driver.