Remove unnecessary edges that maded from intersect(boolean)

Hi, I’m in trouble with removing unnecessary edges inside of face. Look at this picture:

I selected some edge that I want to rid off. Those edges are generated when I used “Intersect(Boolean)” for cutting the face.

But if I just remove those lines, this kind of situation was happened:

I tried to recover the face, but full the face with select boundary edges of empty face is just refill the entire face, even though there were vertices inside, and that is not I want exactly.

So in this situation, is there a safe way to remove those edges? And using “Intersect(Boolean)”, why unnecessary lines were maded? Is there a way to avoid this?

Also using Knife(projection) has same issue.

Those lines are perfectly ugly when I use “smooth”, it renders horrible. Any advice will very appreciate it!

You cannot remove them. Faces cannot have holes in them.

Ok, then is there an alternative way to avoid those kind of situation when using Intersect or knife projection? I mean cutting faces.

Common beginner assumption that those edges are “unnecessary”.

The edges there are needed for Blender to add the holes. But the face still needs to be cut with more edges, not less. All faces that resulted from the cut are n-gons and also concave. Everything gets triangulated in the background and concave n-gon has multiple triangulation options, which can result to overlapping edges in geometry and/or UV’s.

N-gons can distort with normal UV unwrap. Wouldn’t be a big problem on this particular one since unwrap can also be projected from view, which would take care of the distortion.

Concave quad. N-gons have more triangulation variations

Non-planar polygon. Not an issue in this but similar issue that might occur because of triangulation

In the example adding more geometry is the valid solution, but not a generic fix for severely non-planar polygons. Having structure flow follow the form is more universal.