Remove UV Map? Confused

I have a material applied to an object, that has a texture acting as a UV map (that I’ve constructed in the UV Editor). I delete the Material, yet when in Edit Mode, I select a face, the UV editor still show the associated texture. I want to delete the Material, and recreate a new UV map.

Not sure if I understood it right, but… when you delete a material, you are not also deleting textures. Textures will be still asigned to the faces unless you delete them completely* or choose another one.

If you create a new material with a new texture, and you asign it to the object, you still need to asign the new texture to the faces in edit mode at the image editor.

  • Just in case: to delete a texture completely, you need to press Shift and click on the “X”


Shift+X, I didn’t know that.

I thought when you deleted a Material, it automatically deleted the texture. What if I delete the texture in the Material, and then delete the Material… does that help. I’m more so asking so I can understand how Blender sees/reviews textures.

Sometimes I embed a texture, is there a way to remove these later on? I ask because sometimes I embed a texture, then end up using a different texture altogether, and the old textures are seemingly still present because my .blend filesize is still large.

Maybe there’s a place in blender to see all textures used in a tree format? I tried every editor but saw nothing.

Thanks for any input.

Object Data - delete UV map - helps me. To loose images with 0 users you need to save, close and reopen file imho.

Delete texture and then material would help of course. But you can delete the texture anytime.

Embed=Pack? On the image editor, you got an option in the “image” menu to Unpack it.
And in the texture panel, there is also an icon at the left side of the images source filepath to unpack it.
Anyway, you can go straight and use “ShiftX” too on packed images.

Tree view… there is the outliner, you can set it to display Datablocks, then you can see a list of images and textures, but you can’t delete anything from there… which is a pity, because it would be awesome to delete stuff in bulk.


That’s awesome, I had no idea I could go there and delete UV maps.


You’re right, I went into the outliner and expanded some of the levels and saw the textures… and yes, too bad I can’t delete there.

This is going to sound dumb I suppose… but deleting a texture versus Shift+deleting a texture… in not hitting Shift, does that not make it delete permanently and I can access it later? So I’m unlinking the texture in this case and not removing it from the blend?

The only place I can see all of my Image Textures (next to each other) is in the UV Editor. I click the picture icon next to the filename and see all of my resident images (pop-up window)… some of which I’d like to remove. But, I can’t, because I can’t find a way to make them appear in a place which allows me to hit Shift+X. Hopefully that made sense.

Yep, if you don’t use shift, it will remain in the blend file. But just remember you can also just asign a new texture to an object, then the old texture will not be used by that object, but also remain in the blend file.

To delete each image, you need to load it on the image editor (or via texture/image panel), then you can use shiftx.

Hi Zafio,

So in the UV Editor, I select the image via the pop-up menu, hitting the picture icon, and then hit Shift+X. I then go back into the pop-up menu and it’s still there but it has a “0” next to it. I tried again and again, and it still has a “0” next to it. If I select that same image and just hit X (No shift), it’s back in my pop-up without a “0”.

Is it working? And I’ll just have a texture with “0” next to it forever unless I start a new blend?

As Eppo hinted, you need to save, close, and open again to clear it from the list. Anyway, you don’t really need to do it right away, you can keep working on the blend file normally, then, the next time you open it there won’t be any item on the list.


I read that originally before I knew what it meant. Should have went back and reread. Thanks everyone. Problem solved! =)