Renaming objects in 2.8? Outliner only?

I used to rename objects in the ‘n’ panel in 2.79, now I find myself pressing ‘.’ over in the outliner to find my selected object and doing it there - is there a better way?

I saw this:

but I’m not sure if that’s a more complex solution, and I’d rather not install addons if I can do things with the in built tools/UI


To rename active object, just change its name in Object Tab of properties editor.

1 Like

Ah yes! Much easier, thanks!

You can also double-click on any name in the Outliner to rename.

You can now, hit F2 to rename the selected object. Very handy!

It’s also in the Object and Bone context menus as of last night’s build (but you don’t have to tell Bill that since he’s the one who implemented it lol)

1 Like

i want know how to Rename Multiobject. like max rename tool.

This addons very usefull…thankyou .

Seems like there must be more to this, because it’s impossible for me. It worked a few days ago.

Since then, I made lots of changes to the keymap. Maybe I changed something that affects this.

Double-clicking definitely does not let me rename an object in the Outliner today, in 2.82. Just tried it in 2.81a: nope. But it works in 2.79.

It works. But if you changed the keymap to override or disable it, well, then yes it probably doesn’t work.

My problem is that I don’t know what I could have changed that disabled it. Maybe I assigned a double-click to some letter key accidentally.

Yep, that’s it. I just don’t know what I changed. Will dig for it one afternoon when free time arises.

Found and fixed! Thanks for letting me talk it out here; that’s helpful.