Render bloom effect with Eevee

Hello. I wanted to ask if its possible to render Bloom Effect with Eevee Render. I have tried but its not working for me but im not sure if anything needs to be done before bloom effect will be visible. I do know that i can get a bloom effect from compositing but thats not what i’m looking for.

The blendfile itself was too big to upload for some reason so i had to pack it to a rar file
Hammer.rar (2.8 MB)

Do you mean this bloom?
(Suzanne has emission material btw)

Yes thats correct

Problem solved or you still haven’t figured out how to make EEVEE’s bloom work?

i still have problem

You either have to use an emissive material, or have fairly bright lighting in your scene before the bloom will really kick in. It doesn’t hurt to play around with the various sliders under the bloom header in your render settings either, specifically the threshold.

My object does have an emission shader. I’m trying to make a hammer game model and i want a lightning strike around the hammer. So i want a glow effect on this lightning strike. It works just fine in the 3D Viewport but when i render the image the glow is removed

Please, next time you be more detailed and you share some .blend file showing the problem or at least screenshots of your configuration.
I suppose you are falling into this for now Eevee limitation with transparent background:

Sorry. I was actually just going to upload a screenshot. And im not working with a png file but i will have a look anyway, Maybe i can find the solution there anyway. But i upload a screenshot

Main post has been updated

Not necessarily PNG, if you have configured Film > Transparent in render tab, Bloom effect will not be visible in final render result (it is visible in viewport)
But you apparently don’t have Film > Transparent enabled. Could you upload a .blend file here in the forum showing the problem?

Thank you. This kinda solved my issue because i actually have Film > Transparent active. Because i use an HDRI Environment texture map so my shiny parts have something to refflect. But i dont wish to see the actual background in the render so for that reason i had it enabled. So well then i have another issue now. How can i render without trasparency and make the environment texture not visible but the object still refflects the environment texture?

I will upload a blend file

I haven’t understood why are you asking for EEVEE bloom if you’re making a game model that I suppose you’re gonna use in another game engine, so you cant port EEVEE pp effects.
Are you gonna render 2d sprites or 3d models?

Try this.
Obviously your background must be visible, in this case with a solid color but you can use another texture if you want. And use a dark color instead of the green to make the bloom more easily visible.

Sorry for not explaining properly. It is a game model but i just want to render the image. For now i have no plans to export it in to a game engine. I know the bloom effect wont be visible in a game. I just want to render the image and have the lightning bolt animated.

And thanks, i will try your node setup

Thank you so very much. This solved all my problems !