Render layers not combined properly

I’ve set the red cube in second layer, copied the camera and set the transparent sky in render settings.
Compositor combines 2 layers.

test.blend (593 KB)

  • How to set the layers so that lighting and materials which affect red cube, are rendered properly? Render is not showing red material and light information from first scene.
  • How to render only the second layer with transparent background but with scene information of first layer? This is rendered only second layer

What is interesting, if you change to Cycles and check Film>Transparent you get the correct render. Is this a bug for Blender Render?

There is no light on your “Render Layer.001”, so naturally the cube is pitch black…
Put your lights on another scene layer, e. g. #3. After that, set “Render Layer” to include scene layers 1 and 3.
And set “Render Layer.001” to include scene layers 2 and 3.

This should light anything.

Ok, but if you select Cycles and check Film>transparent you get the the wanted result without setting the lights in 3rd layer.
So, Cycles gives you desired result. Shouldn’t render layers workflow and combining them in compositor be the same in both engines?

Not sure what your point is supposed to be.
Blender Internal and Cycles are completely different render engines. That’s why their lighting systems also work differently, which is what you’re seeing in your file. This is not a render layers workflow thing, but a side effect of how Cycles’ lights work compared to Blender Internal’s lights.

Apples and pears…

Well, objects and lights on RL1 affect RL2 in Cycles when combined in Compositor. That is not the case with Blender Render.
Shouldn’t this be connected only with the scenes and layers?
I understand they operate the light differently but I thought that render layers should act the same in both engines.

I agree with Soul. It most certainly is a “render layers workflow thing”. Blender internal doesn’t use lights from layers that are shut off in the render layer, cycles does. In cycles if you don’t want the lights from those layers you have to exclude them. Since the devs added the exclude check boxes to the cycles settings I assume it was a by design change to the render layer operation.

To say it’s just because Cycles calculates lights differently, doesn’t take into account that what’s being discussed is render layers workflow.