Render pixelated

Hi, I’m new to this forum and relatively new to Blender. I’m trying to follow Blender Guru’s Realistic Earth tutorial but I can’t seem to figure out why the image turns out pixelated after a render. I’ve followed the tutorial carefully step by step but obviously I’m doing something wrong here…

Have you tried rendering at 100% scale, you are currently rendering at 50% of the set render dimensions.
Also view your rendered image at 1:1 size (numpad 1 or View menu) to ensure no scaling issues

Thanks. So, it should be viewed as 1:1 scale. In the tutorial the earth looked so much bigger than on my screen, so I guess I zoomed it in.

Just to emphasize what Richard already said:

  • render at a decent resolution, but typing in the pixel values and then using 50% should not cause any issues, it really only renders half the amount of what you typed in.
  • check your Anti-Aliasing, see if 16 samples resolves your problem. Usually you can get away with less than 16, but this value should give a decent result in most cases and also with your sphere.
  • 100% view, so 1:1 size in the image editor is very important, since every other zoom-level disregards your Anti-Aliasing settings and will most likely look jagged.