Render shadows onto object, but not the object itself

I’ve been trying to figure this out all day. How can I have an object that receives shadows, render showing the shadow, but not itself? To help make more sense, I’m trying to render 3d over live action.

in the material properties of the said object, the option “only shad” will recieve a shadow but not be rendered itself. the option " only cast" will make the object make a shadow but not be rendered itself.

atatched is an image showing the location of the buttons.


I’ve tried those and they didn’t work. I’ve tried using render layers and almost gotten it to work. Here’s what I’ve got.

I want a shadow cast on the ground, and ive only gotten a shadow from the ambient occlusion, not the light i put in the room. I used layers, one layer, with the floor, is set to only show shadows. It’s only half work so far.

could you post the .blend file please.