Rendering Artifacts, also visible in camera perspective

Hello, I’m pretty new to Blender.

I’m curious how to correct these artifacts / glitches that appear on these meshes. They don’t appear in normal 3D view, only during final rendering, and in the camera perspective.

1st-Render, 2nd-Camera Perspective, 3rd-3dview


You should give more details, wireframe views or the scene.
For now you should ensure your objects have scale (1, 1, 1). If not so you can Ctrl A ->Scale in 3d viewport to Apply Scale to selected.

paolo

Hey. Thanks for that hint, I might look at what that means. But for now, I think I just have some wrong settings inside the camera :o

I flied around using that camera and pretty much a lot flickered…

:eek: Found it…

Feeling like a retard. The “clipping value” in the camera was set to “start: 0.001”
Increasing it solved it. Oh…my, god.

I’m so glad nothing more serious was happening, phew. (this could’ve been a lot worse…) Thanks for that Scale thing.

http://i52.photobucket.com/albums/g25/rueckwaerts/resolved3.jpg

Happy you solved it. :slight_smile:
Yes, making object to have scale=1 is always a good precaution to avoid artifacts or, in case of cycles rendering, to get a more realistic materials behavior and camera Depth of Field.

paolo