Rendering artifacts?

Hi, please help on the following issue. I have spent pretty much time and have no idea how to fix it.

Blender 2.54. I have attached some screen shots and the blend file. The only changes I did to the regular cube are:

  • removed one face so we can look inside
  • created material and marked “transparency” (raytray) however alpha is 1.0
  • set “smooth”

When I render there are sort of mesh triangles visible - what is that? I have notice if I disable antialiasing OR disable material transparency the problem disapears. Please help!


t2.blend (437 KB)

not sure why, but if you set z-transparency it is fine.

I’ve noticed that too, however I guess it’s not a solution. I know it’s beta ver however it’s still difficult to imagine it’s a bug - it’s so easy to reproduce… It basically means almost all basic renderings will have such annoying issue…

Your problem has to do with normals; If you flip the normals, the problem faces flip with it.
Blender is confused on which one is inside and which on is outside. You need to have at lease some thickness for blender to render the double face correctly.

adding a solidify modifier fixes this problem. I also added a subsurf modifier and edge split modifier to make it look nicer.
the one to the back right is the original, the front one is the fixed one


fixed.blend (473 KB)

Thank you! That definitely clarifies a lot (and let me solve the issue). However, one more question - does it mean there’s a general rule in 2.5 (it didn’t work like that in 4.x) that whenever I have a semi-transparent mesh or the one which has a hole in it, it has to be thick? I have another example when the mesh is CLOSED (no holes) but it’s semi transparent (let’s say alpha=0.6) - in such a case the artifacts are visible also.

I’m not sure. I can’t see the mesh.

Hay Veedoo,

I got some conclusions about this problem:

1.I downloaded your Blend and when I used one of the latest blender builds from your Blend was rendered out perfectly: But when I used the *official 2.54 beta, I got that “triangles” bug that you got, so it seems to me that this is a 2.54 beta bug.

2.If your goal is to only view inside the mesh from the top, you don’t need transparency, and if you decide you want transparency in your scene anyway, it seems that “Z transparency” overcomes that “triangles” bug that we get with “Raytrace”.

Oh and Just a quick tip: you can use the Edge Split modifier to get rid of those “black effects” you get from setting “smooth”

*When I wrote “official 2.54 beta” I meant 2.54 beta from site.

Anyway, good luck!