Rendering issue with .stl

I’m working with .stl files from our engineering department that’s using Pro/E. When I use a subsurf modifier and increase the render levels, the surfaces and cutout shapes distort. Is there something I can do to prevent this? Do I need to “convert” the .stl files prior to bringing them into blender?

Please no that I am a newbie to blender and the 3D world!

Thanks for your help!!!

Subsurf will do that to edges that are not connected to something else. But could you post a screen shot of what you are having roblems with?

Get the engineering department to output the files as .slp (Render) and import to Blender using the dedicated ProE importer.

Tell them to export with the settings as 0 for the first option (chord height if I remember correctly, ProE will then say the min chord height is 0.0xxx, select that. The second setting (angle, I think should be set to 1) This will output the maximum amount of triangles and you wont have to add any subdivision. Then autosmooth and adjust the smooth angle in Blender for a lovely model.

I use ProE to Blender for rendering regularly.:slight_smile:


Ricky Dee
http://www.digital-air.co.uk/

Here are some images of what happens…

Attachments



I’ve posted the images of the subsurf modifier. If my edges aren’t connected, how do I connect them?

Thanks,

Must you use the modifier? I think Ardee knows whereof he speaks. Have you tried simple subdivision?

maybe just set some of these hard edges to smooth; i think the modell is subdivided enough.

S.

I am having the same issue with .stl files. I first requested engineering to export the files in .slp, but they had no clue how to do this. Is there a plug-in or program that is required to export to .slp in Pro/E?
Can someone provide a process to export .slp from Pro/E?

Your help is appreciated.

I think the .stl isn’t the problem.
you just need to:

  1. mark all edges you want to be sharp as sharp edges.
  2. use edgeSplit modifier
  3. recalculate normals outside

hope this helpes

Could you post a wire of the model? do you have lot’s of tris in the model and maybe also a lot of small faces? This can lead to artifacts using subsurf.

As mentioned before try to use set Smooth and the “autosmooth” button or set Smooth and the edgesplit modifier. You do not have to mark all edges sharp it should be enough to play with the angle setting.

I was going to slag off the quality of your Engineer’s but I’ve just noticed your location so don’t need to bother :no:

Exporting a .slp from Pro/E is as simple as “Save A Copy” and set the file type. (all data from Pro/E is exported this way)

1.In Pro/E select File–>Save a Copy (this opens the file dialogue box)
2. Change the file type, Type–>Render(*.slp)
3. Click “OK” this opens the “Export Render” dialogue
4. Change the “Chord Height” value to 0 (zero) Pro/E will then set it to the smallest value possible depending on the file.
5. Change the Angle Control to 1.0000 (steps 4 and 5 control the number of triangles in the exported file so play about with the values to reduce file sizes but decrease quality. The settings I mentioned will give maximum quality).
6. Click “Apply” and then “OK”
7. Pro/E will triangulate the parts and export the file.

Works great on assemblies. I use it all the time.

If you’re running Wildfire 2 and above you can export to .obj if you want (this used to always crash Pro/E but seems to have been fixed now). Procedure is as above but set your filetype to Wavefront(*.obj)

HTH, if it doesn’t get some decent Engineers :wink:


http://www.digital-air.co.uk